5

I'm downloading some files through a program called Metatrader and trying to save it with the Save File dialog under a sub-directory of the software (in Program Files), but under Windows Explorer I can't see the files.

Where did Windows 7 store them?

5

The files that you downloaded were virtualized. To view them in explorer you have to click Compatibility Files button that appears on the explorer bar. This button only appears in directories that contain virtualized files.

Windows virtualizes files saved to Program Files (and some other directories) in certain programs for compatibility issues. Click here to read more: http://support.microsoft.com/kb/927387

| improve this answer | |
  • I had no idea Windows did that until reading this post. Very helpful! I pulling [what remains of] my hair out trying to find a file I just saved. – Drew Chapin Sep 13 '16 at 19:16
4

I had the same issue with the print (& save to file) dialog box in IE. I could see the file in the dialog box, but not thru windows explorer.

I could finally locate the file at this location:

C:\Users\username\AppData\Local\Microsoft\Windows\Temporary Internet Files\Virtualized\C\Users\username\Documents\

I got to know the exact location by opening up the file in the dialog box thru my text editor. I then went to that location in windows explorer and "rescued" the files off to where I wanted them originally.

| improve this answer | |
0

The software might not be saving the files actually, because saving to Program Files requires UAC elevation (unless you have UAC disabled). Are you running metatrader as an Administrator?

Also try enabling the display of hidden files and system files by going to Folder options.

| improve this answer | |
  • Yes it is saving because I've done so for 3 days so I can see all the past files I already saved there through file dialog but I didn't realize until today I could not use them outside of metatrader :) No I didn't launch as administrator. – asksuperuser May 2 '10 at 17:49
  • I'm new to windows 7, I can't see any option for unhiding files in folder properties ? What I've is that I zipped under file dialog that's how I did get my files ! – asksuperuser May 2 '10 at 17:55
  • i43.tinypic.com/2lkwr3q.png and i40.tinypic.com/jfaozt.png Select "Show hidden files, folders and drives" and uncheck "Hide protected operating system files" (although the latter may not help at all, but worth a try) – Om Nom Nom May 2 '10 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy