1

I need to setup a docker container running an Asterisk PBX.

The problem is that I receive the wrong ip in sdp replies. In fact Asterisk is using the container internal IP.

The second problem is that I must use docker for windows and as such, I can’t use —net=host

So I tried to setup nat in asterisk, setting in sip.conf this :

nat = force_rport,comedia
localnet = 172.17.0.0/16
externaddr = 192.165.10.206

But it doesn’t seems to do anything.

What to I miss here ?

PS : I am using Asterisk 15

  • Is your situation similar to the one described in this article? How have you constructed the container and did you use one of the available ready-made images? – harrymc Oct 31 '18 at 9:47
  • I have used the andrius/asterisk ready made image. It consist of a Alpine Linux and an Asterisk deployed with the native Alpine packages. I already tried instructions from the article you mention, and it doesn't seems to works. – iXô Oct 31 '18 at 10:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.