2

I have Microsoft sculpt ergonomic keyboard which wakes up my monitor as soon as display is turned off due to power setting. As a result, display is momentarily turned off and then turned on right away. Effectively this is keeping my display on forever.

Following link mentions the problem but there is no solution:

https://answers.microsoft.com/en-us/windows/forum/windows_10-power/microsoft-sculpt-ergonomic-keyboard-waking-up-my/e0ac7dac-2395-4ab1-acd6-46c8e49c6f9d?auth=1

Is there any remedy for this? I have updated OS patches, device drivers and everything...

  • The workaround mentioned in the last post of the forum thread you linked should work. Also disable any wake-up from USB feature in BIOS/UEFI. – user931000 Oct 24 '18 at 13:58
  • @GabrielaGarcia, I tried all those things. Also, changed BIOS settings. This is not getting fixed. I have another machine which was upgraded from Win-7 to Win-10, that machine doesn't have this problem. The brand new dell machine with Win-10 shows this issue. I have isolated the problem to MS keyboard dongle but there doesn't seem to be any fix. – PAS Oct 24 '18 at 14:32
  • @GabrielaGarcia, sorry, I was changing wrong setting. This indeed is working. – PAS Nov 4 '18 at 14:59
2

Unchecking device manager->Human Interface Devices->Microsoft Hardware USB Keyboard->Power Management -> Allow the computer to turn off this device to save power, is indeed fixing this problem.

enter image description here

| improve this answer | |
  • This did the trick for me too – Yugo Dec 15 '19 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.