I'm running Windows Vista Service Pack 2.

I have the Folder Options set to "Open each folder in the same window."
(Organize | Folder Options | General).

Each time I open a folder, it opens in a new window.

How do I get it to open each folder in the same window?

I have tried the following techniques with no success:

  1. Expand number of MBAG entries in Registry. (The number is 40,000 now.)
  2. Delete Bags and MBAG entries in Registry. (Rebooted machine after, still no success).
  3. Change to "Open each folder in its own window". Saved, then changed back.
  4. Under View tab, changed "Remember each folder's view settings":
    unchecked, Apply to Folders, checked, Apply to folders.
  5. Applied application from Annoyances.org. Still no success.
  6. Clicked on Reset Default Options, then OK. (Opening in same fold is a default option!)
    Still unsucessful.

I want the folders to open in the same window, just like the options say.


Some software that you have installed or uninstalled must have monkeyed with your registry.

Here are some things that you may try:

  1. In regedit, goto to key HKEY_CLASSES_ROOT\Directory\shell and make sure that "(Default)" has no value.

  2. In regedit, goto key HKEY_CLASSES_ROOT\Folder\shell\explore\command and replace /separate with /same like this:
    %SystemRoot%\Explorer.exe /same ,/e,/idlist,%I,%L

  3. See this article for another solution: Fix Open each folder in the same window "bug".

Please take the usual precautions before editing the registry:
Export the keys as backup before modifying, and also create a system restore point.
Undo any suggested fix that doesn't work for you.

  • Finally, solution #3 worked. Many thanks. The new windows gets irritating after 4 levels of folders. – Thomas Matthews May 4 '10 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.