Not a single answer from here worked for me.

I want to delete the .resource association with Total Commander.

Approach 1

I open registry, go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\\.resource\OpenWithList and remove there all I can.

enter image description here

It does not work, the default app is still there.

Approach 2

I create a dumb .exe. Right click a file .resource select open with and check to always use the app as a default one. When time comes for the file to be opened I am presented with a window that tells me that .exe can not be used for opening the file. And hence again I did not remove the Total Commander as default opener of .resource.

enter image description here

enter image description here

Approach 3

I right click Window button. Go to Apps and Features -> Default apps -> Choose default app by file type -> Scroll until find the .resource extension and see that there are not options except Total Commander. Again I was not able to remove the default open with app.

enter image description here

4 Approach

Win+R -> cmd.exe -> ASSOC .resource= -> check that file association is gone, but it is not gone.

enter image description here

That is really crazy. What can I do to solve the issue?


1 Answer 1


Simply save the below Reg File to a .reg extension named text file and then run the elevated command of ASSOC .resource=. Afterwards, double click the Reg File to remove that registry key and its content from the registry to fully disassociate the file extension from opening with any apps.

Reg File

Windows Registry Editor Version 5.00


enter image description here

Now when you go to open the .resource file, it will no longer have any application association and prompt you to tell it what app to open with.

You can delete this key manually by navigating to it via regedit and then pressing Delete too. enter image description here

Additional Resources

  • @YaroslavTrofimov - If you wanted to be extra thorough you could also run the admin elevated command prompt commands of: taskkill /f /im explorer.exe && explorer to kill explorer and start a new instance of it after you make the 2 changes as listed above. Oct 25, 2018 at 0:13
  • 1
    This was only half the answer for me. I needed to also delete the same sub key from HKEY_CLASSES_ROOT. See superuser.com/questions/49615/… Aug 5, 2019 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .