0

When I try to use my webcam for livestrams on YouTube, the site tells me the cam is in use by another application. No matter what I try, YouTube won't let me use this cam.

What I have tried:

  • I have used this cam before multiple times on a different machine, there were never any issues.
  • I tested the camera with the Windows 10 Camera application. It does still work.
  • I looked for processes using this camera using the Process Explorer. I found nothing.
  • I tried deactivating-rebooting-reactivating the camera in hardware manager.
  • I Installed the original drivers from Logitech and those that Windows 10 recommends.
  • I tried using Microsoft Edge to stream but YouTube does not support that.
  • Using Microsoft Edge I visited the website webcamtoy. It reports "camera not found".
  • Played around with the settings under Settings > Privacy > Camera. No solution.
  • Of course I spent two hours searching the internet for appropriate solutions.

I am talking about a Logitech C920 on Windows 10 and the latest version of Chrome.

Thank you.

Even though the solution was the same, there is no apparent connection between this issue and the standby issue I describe in my solution. In my opinion, even though quite specific, this question and answer might help other users to find help.

  • When I had a similar problem with Skype a few years ago it turned out to be a USB driver issue. Since the Logitech C920 is a USB camera I would start there, with my problem UWP applications could access the camera, but traditional Win32 applications could not. In my case I had installed some ASUS drivers designed to charge devices, the driver caused a problem and wasn't necessary for my system to run. I am not submitting this as an answer for obvious reasons, I am just pointing you, in the correct diagnostic direction. – Ramhound Oct 26 '18 at 8:18
  • Thank you for your input. As far as I understand Chrome is a 64-bit-aplication. And it does indeed know there is a camera (when I unplug it the error message is along the lines of "no camera found"). Also, this is a completely new machine with very few applications installed - and even more removed like Skype etc. so there seem to be few options. But I will look into all my USB-related connections. – fertchen Oct 26 '18 at 10:44
  • I am not sure what Chrome being a 64-bit Win32 application has to do with anything I said. – Ramhound Oct 26 '18 at 11:06
  • Sorry, in my installing-everything-again-frenzy I misread that for 32-bit. As I said, I will check everything USB-related. – fertchen Oct 26 '18 at 13:05
  • 1
0

As strange as it may sound: Entering BIOS and enabling CEC 2019 fixed this issue. The webcam is now available for Chrome. I came across this setting while trying to fix this power/standby issue.

|improve this answer|||||
  • And what is the downvote for? – fertchen Oct 28 '18 at 7:35
  • You have simply linked to another one of your answers. – Ramhound Oct 28 '18 at 7:48
  • I have not simply linked to another of my answers but also posted the actual and precise solution to the problem right here. What is wrong about that and why does it merit a downvote? Please explain. – fertchen Oct 28 '18 at 14:44
-1

Windows 10 Setting > Privacy > Camera

Using Windows 10 Settings, you can manage and choose the Apps that can have access to your webcam and use your camera. open Setting (WinKey+i > privacy > Camera. Here you will see the list of apps that have access to your webcam.

Disable access to camera for other applications. if problem still persist on, It maybe a problem from your Antivirus Webcam Shield feature. Simply disable the features of antivirus for testing purpose.

|improve this answer|||||
  • Those settings only apply to UWP applications, Chrome is not a UWP application, thus would not honor those settings. – Ramhound Oct 26 '18 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.