2

I'm using Windows 10 and I wanted .pie files to be opened with a jar file I created, so I used assoc and ftype as follows:

assoc .pie PieLang
ftype PieLang=java -jar pielang.jar "%1"

assoc .pie does return .pie = PieLang, and ftpe PieLang does return PieLang=java -jar pielang.jar "%1", so everything should work.

However, everytime I open a .pie file, no matter if I do it using double click or using CMD, it will always open with Notepad.

Is there any way I can fix that?

EDIT: Now I can't change .py files either. But somehow pdf files it does let me change

EDIT2: It doesn't work on file properties as well. Instead, when I choose a program as default on the menu, it opens on that program one time, but it doesn't change the default

EDIT3: Ramhound's solution doesn't work as I said before.

(Asked in StackOverflow and my question was marked "on hold" and they told me to post my question here, so I did)

  • 1
    SuperUser is definitely the place to ask this, so you got that part sorted. If you select the file in explorer, then right-click -> open with -> other program -> check always open this program and select the right program, does that work? Can you associate it with anything else at all? – LPChip Oct 27 '18 at 21:42
  • @LPChip It doesn't work either apparently – Argaman Oct 27 '18 at 21:48
  • @Ramhound What do you mean it's a known issue? Windows just let this issue stay as it is? – Argaman Oct 27 '18 at 22:12
  • @Ramhound I don't understand what do you mean, I am pretty new to all this stuff, Can you please explain a bit more? – Argaman Oct 27 '18 at 22:22
  • The bug is known and will be fixed in a future patch. – Ramhound Oct 27 '18 at 22:42
-1

if you have associeted your file .pie opens automatically with another program, then you have to do : go in settings->system and search app default for type file.(Here you can solve the problem)

Sorry uf the name is different but i have italian language and i don't know which is tne real name on windows 10 in english... i hope this help you

  • 1
    Thanks for trying to help, but it's not my problem :) – Argaman Oct 27 '18 at 22:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.