I have two separate PCs (a desktop and a notebook):

  • with exactly the same version of Windows 10,
  • connected to the same home network,

where one of them (notebook, connecting via WiFi) is unable to access one of the devices (TV player) while having absolutely no problems connecting to all other devices (other PCs).

We have four devices in home network:

  • a TV player, connected via a cable, with some own implementation of Linux,
  • a desktop PC, connected via a cable, with Windows 10,
  • a notebook PC, connected via WiFi, with Windows 10,
  • a notebook PC, connected via cable, with Windows 7.

The connection problem exists only on notebook (Windows 10) --> TV player (Linux). All other PCs and devices connects to each other without any problems (to my extreme surprise there was no problem even in connecting Windows 7 to Windows 10) and can access all shares at once.

Since that problematic PC is the only one in my network that connects via WiFi1 then I expect that this is the source of my problem.

Can someone confirm this? Is there any dependency between Samba shares or Samba protocol in general and WiFi or the way how accessing devices are connected to local network?

Is there anything I can check or do to fix this problem?

1There are many other devices that connects via WiFi. But they gain no access neither to network shares nor to the home network itself. They only use it to access the Internet. So they are all probably out of equation.

  • 2
    I suspect the SMB revision. SMB1 support has been removed from Windows 10 by default, but it can still be added in Windows Features, although it would be better to add SMB2 to your TV player, if you can. – AFH Oct 28 '18 at 15:59
  • Do you suggest that my player uses SMB1 (it is quite very old indeed) while all other machines supports SMB2 and that's the reason? Am I getting you correct? – trejder Oct 29 '18 at 19:36
  • Just so. I guess one of the Win10 systems has SMB1 already included, since you say that one of these machines has full network accessibility. – AFH Oct 29 '18 at 22:39
  • I think you can turn these comments into an answer, if you wish me to accept it and bring you some rep. It would be a good idea to point out exactly where and what to look for. I went to App & Features section (new in Windows 10) and found nothing. Only then I went to "old" Windows Features in Control Panel to find something, I think, you're talking about ("SMB 1.0 Client & Server"). – trejder Nov 4 '18 at 19:30
  • 1
    Thanks for the suggestion. I've been away and have rather a lot to do over the next couple of days, but I'll look at making an answer when I can. – AFH Nov 6 '18 at 16:58

When I have encountered this (most recently on my NAS enclosures), I found the reason to be that later Windows 10 releases have removed SMB1 support by default, even though older hardware might have been programmed using it.

The best answer is to upgrade the device (in your case, the TV player) to SMB2 or later, but if this is not possible or practicable (as with my NAS) there is still an option to add SMB1 to Windows through Programs and Features:

Control Panel

Click Turn Windows features on or off, then select SMB 1.0/CIFS File Sharing Support:

Windows Features

I can't remember if I needed to restart before SMB1 communications were enabled.

Be aware that SMB1 was disabled because of security defects, so make sure your firewalls are enabled and up-to-date.

I have no idea how long this will remain an option: if it's removed from future releases, then we'll need to find a third-party implementation, but it provides an answer for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.