0
takeown /f  "C:\Program Files (x86)\AlibabaProtect
sc delete AlibabaProtect

I ran the above and killed "Alibaba PC Safe Service" via Task Manager. Then I ran the following:

rmdir /s /q "C:\Program Files (x86)\AlibabaProtect"

Both the service and folder were successfully removed. However, after I rebooted the PC, both came back. How can I remove them permanently?

  • 1
    Stop the service, disable the service, kill the process, then try to delete the folder. – LPChip Oct 29 '18 at 15:27
  • Also, see if you can't just uninstall this from the Control Panel. Often it has an uninstaller. – LPChip Oct 29 '18 at 15:28
  • Are you running an elevated command prompt? – spikey_richie Oct 29 '18 at 16:12
  • Mark the service in the Services applet as Disabled, reboot and delete it. – harrymc Oct 29 '18 at 18:27
  • I have edited my question. Please read it again. – Matthew Wai Oct 30 '18 at 4:33
0

I just found that the problem can simply be solved by deleting the "AliUpdater" task on Task Scheduler. AliUpdater will download and install everything again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.