I keep setting the starting page manually to empty, but after each plugin install or firefox update it is again set to the firefox starting page.

Is this normal behaviour? Or could the be beause of a plugin? Or some setting, or hidden setting?

This is ff 3.12 on windows 2003. I want an emtpy starting page.

edit: The trick from the accepted solutions solved it. I had just blanked out the field, and in this case firefox always sets it back to the firefox starting page. Setting it to "about:blank" works.


Try setting the homepage to about:blank

That should hopefully keep the empty blank from being overwritten.


This is definately not typical. I have been using FF for a very long time and have not seen this ever happen to me.

One suggestion is to set a homepage that is blank instead of just clicking on the radio button that tells FF to start with a blank page. This may solve your problem.


Is something set to read-only? Perhaps it's not really saving. Perhaps you're not running with the permissions that are unexpected?

  • i checked and it does not seem to be the case. thank you anyhow! – user3900 Jul 27 '09 at 17:02

Goto Tools Menu - Options - Main - When Firefox starts : show a blank page (instead of home page)

This should work as you are just deleting the home page url

EDIT:If you are not using Firefox 3.5.* you can use Tabs mix plus for session management it's better.(I usually use it select tabs by mouse over,so that i don't have to click)

  • sorry, i forgot to mention this in the question: i am using session management, and this setting must be set to "show opeb tabs of last session" – user3900 Jul 27 '09 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.