4

I am trying to switch from gnome-shell to awesome on fedora 28.

The problem I have is that when I try sudo awesome -r it tells me that another window manager is already running. So I have tried killall gnome-shell && awesome & but then the screen turns black and there are usually some ^@ symbols all over the screen. At this point I do not know what went wrong and all I am able to do is reboot.

I would be glad if someone could explain to me what I did wrong and what I have to do to activate awesome.

2 Answers 2

1

If awesome is installed, you should be able to logout and choose it from the login page, using the icon that is placed next to the "Sign In" button.

An alternate solution is to install the switchdesk and switchdesk-gui packages and run the Desktop Switching Tool application, where you can select the default desktop from the list and confirm.

4
  • Ok thanks it worked, there was an option in the login screen. But is there a reason you cannot run awesome from the terminal?
    – iaquobe
    Oct 29, 2018 at 19:04
  • You can run awesome from the terminal, you just can't run it while also running another window manager. If you booted directly into a TTY you could run it with awesome &. Oct 29, 2018 at 19:14
  • I thought after killing the gnome-shell there shouldn't be another window manager running.
    – iaquobe
    Oct 29, 2018 at 19:24
  • I believe (but I'm not sure) that GNOME will attempt to automatically restart itself when it crashes or is killed. I may be wrong about that but I know that XFCE does. Not sure why it was just spewing random symbols and freezing the screen though. Oct 29, 2018 at 19:30
0

An alternative solution is to use the --replace flag, e.g., awesome --replace &. Source: https://awesomewm.org/doc/manpages/awesome.1.html

Many window managers support the --replace flag.

2
  • I tried it but it didn't work. The man page also says that -r and --replace are the same thing but neither of those worked for me.
    – iaquobe
    Oct 29, 2018 at 19:26
  • Ah, yeah I didn't notice the -r in your original post. That's odd, maybe GNOME just doesn't play nice with awesome. That would make sense since GNOME is definitely not awesome ;) Oct 29, 2018 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.