1

Due to a particular reason, not important here, I need to share VPN connection via WiFi to multiple embedded devices. One way is specialized wireless router, expensive and clumsy. The other, quite beautiful way is homemade router using Raspberry Pi and OpenVPN+hostapd+proper routing in a nice handy case, which is the way I solved it and worked brilliantly.

But, alas, I stupidly forgot my device at home, and now I am stuck for a week in a place where no shop is selling raspberry Pi devices. I have multiple devices that need to be connected via WiFi as follows:

  • Every device needs access to the internet via VPN
  • They all have WiFi interfaces, work as clients
  • Just some of them support VPN client functionality
  • The devices need to communicate among themselves as well, inside the local network, which is then routed to outside world via VPN.

I had great idea to use laptop with Windows 7 for this purpose, by combining SoftAP functionality built into Windows via Wireless Hosted network (https://docs.microsoft.com/en-us/windows/desktop/nativewifi/about-the-wireless-hosted-network) , OpenVPN and Internet Connection Sharing.

It works. However, to my horror, devices, after they are connected to the laptop (pretending to be Access point) seem to be isolated from each other. Ping does not get across, for example (I can ping the devices from the laptop and vice versa, but cannot ping device 1 from device 2).

Now, client isolation is well known functionality in public WiFi networks, but I cannot find absolutely any kind of documentation on this topic as related to SoftAP/Wireless hosted network/ICS.

Is there a way to switch it off so the devices can "see" each other? Registry setting? I tried to disable the firewall on the laptop, to no avail. Especially jarring is the fact that stated purpose of SoftAP in windows is "personal area network", where one would really expect a degree of possible intimacy between the clients.

Any ideas?

0

At the end, I solved the problem by digging out ancient notebook (it still had 3.5" floppy drive, LOL) with 2GB RAM and installing Ubuntu 16.04 LTS on it.

The setup is far more clumsier, new distributions (18.04) do not support 32 bit anymore, and the notebook contained the dreaded SiS graphics chip which randomly put the computer to sleep, until I fully disabled power management.

Raspberry Pi works much more reliably and I don't recommend the above setup - it was really a last resort.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.