0

A few days ago I have updated my distribution(OpenSuse Tumbleweed with Gnome) to the latest version and I am no longer able to get my external HDMI monitor working.

The error I get when I run intel-virtual-output is No VIRTUAL outputs on ":0".

I am also unable to see the HDMI port anymore in xrandr:

gardax@linux-oyrd:~> xrandr -q
    Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
    XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
       1920x1080     59.96*+

Does anybody have some ideas on what may be the problem?

Some information that I think may be useful:

I have an Optimus HP laptop. My kernel version is 4.18.9. I have installed my drivers and bumblebee following this guide.

My /etc/bumblebee/bumblebee.conf file looks like:

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=true
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib64/primus:/usr/lib/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=none
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib64/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib64/nvidia/xorg/,/usr/lib64/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=none
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

My /etc/bumblebee/xorg.conf.nvidia config is like that:

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "true"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    Option "ProbeAllGpus" "false"
    Option "NoLogo" "true"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "DiscreteNVidia"
EndSection

I have a /usr/share/X11/xorg.conf.d/20-intel.conf file with:

Section "Device"
    Identifier "intelgpu0"
    Driver "intel"
    Option "VirtualHeads" "2"
EndSection
  • In this post it was counseled to get a 2X1 HDMI switch, so that normal HDMI connections can be used on every end and xrandr and xorg will recognize the TV automatically (example). – harrymc Nov 7 '18 at 9:11
  • Try to install the proprietary NVIDIA driver as detailed here: SDB:NVIDIA Bumblebee. To be able to use the HDMI output, see also the procedure in this thread. You might need to add a dummy "nvidia" section to /etc/X11/xorg.conf.d/ and a dummy "intel" section to /etc/bumblebee/xorg.conf.nvidia. – harrymc Nov 8 '18 at 8:47
  • @Gardax Try to boot (from a full stop, no freeze/hybernation) with the HDMI cable already plugged (both sides) and with the Monitor/Television turned on. Try to use a different OS (even the same flavor/version, but a different one, maybe a boot-able Usb pen drive) and if successful look for the differences. Eventually leave only the HDMI monitor connected before the boot. BTW were you with the same drivers before the upgrade, when it was still working? – Hastur Nov 8 '18 at 22:03
0

Your nvidia X is supposed to be on :8
export DISPLAY=:8 LD_LIBRARY_PATH=/usr/lib/nvidia-current:$LD_LIBRARY_PATH

As per: https://github.com/Bumblebee-Project/Bumblebee/wiki/Multi-monitor-setup

Often people having trouble have some luck with the method of switching to tty1 before logging into a window manager, and manually forcing their options:
CTRL-ALT-F1
sudo systemctl stop lightdm whatever your display mananger
export DISPLAY=:8.0
optirun startlxde whatever your command for starting your window manager may be

  • I have tried to change it to :8 but I get another error: Unable to connect to ":8". – Gardax Nov 4 '18 at 18:42
  • It sounds like the kernel isn't loading the module then or bumblebeed isn't starting. – Stuart Gray Nov 15 '18 at 20:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.