I've recently found an old (circa 2006) MAXDATA laptop and began to think whether it's possible to squeeze some more use out of it. It's still working perfectly fine (apart from the battery life being nonexistent and a bit of overheating problems), however its only OS is Win XP. Seeing how I'd like to be able to browse the Internet on it (safely), I decided to install a linux distro - and that's where it all started.

I used YUMI to make a bootable USB with 3 distros (then checked if the USB worked - it did), then plugged it into the laptop and chose boot option named 'Removable Dev.'. The screen turned black and an underline (cursor) started appearing and disappearing. I left it for about 10 minutes thinking it needs some time to boot, but nothing else happened.

Of course, I checked the BIOS next - found some options like 'USB Device Boot Support', 'Boot Sector Virus Protection' and 'Boot Device Priority', then tried changing them all up - nothing seemed to make any difference. Then I tried to boot another OS from a CD-ROM (some old rescue disc), and it worked perfectly fine. I also noticed a list in the BIOS called 'IDE Configuration', which 'displayed the status of auto detection of IDE devices'. Only the 'Hard Disk' and 'ATAPI CDROM' options were present, nothing about any USB drives.

My question is, am I doing something wrong or is this computer simply not able to boot from flash drives despite there being options in the BIOS specifically for it? Should I try to make another USB drive with just 1 distro? Does it matter which distro and which program to use to burn it? Or should I simply go buy a clean DVD-R and burn the distro there? Any help would be much appreciated.

  • Please improve you're post by using paragraphs! – Albin Oct 30 '18 at 13:55

I have found problems usually with old machines when booting from USB. Despite that, a computer from 2006 should not be "so old" for this.

Check if the USB drive is listed under hard drive boot priority. Most old computers tend to list usb drives as internal disk and not as USB drives in BIOS. Check also that the pendrive is formatted with legacy MBR partition system and not modern GPT/UEFI. Sometimes a particular motherboard does not like a particular brand/model of pendrive and you cannot do much about it.

It is expected that the drive is not shown as an IDE drive, you will only see IDE hard disks and CDROM drives there.

One thing that solved similar issues for me (like installing a VM from scratch directly from a bootable USB) was using a little useful free program called plop boot manager: https://www.plop.at/en/bootmanagers.html , it is a small program that helps you boot from a number of sources (USB between them). You will still have to buy a CD/DVD to burn software like this, but the benefit is that you will likely only need to do that once and you keep the utility for another uses.

  • Thank you very much, the program worked flawlessly! – wr1tr Oct 30 '18 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.