1

I have a brand new Windows 10 laptop and I try to connect to our SMB NAS. For some reason I cannot get connected and troubleshooting is quite hard as well.

I know the server is online, because other computers (also Windows 10) in the network can connect using "Connect to network drive". Also, the IP address is pingable from the laptop.

What could cause this not to work, and what tools do I have available to check if the share is available?

I have tried net view, but also on the desktop where the share did work, this didn't show me the name of the server.

The server is a FreeNAS (FreeNAS-9.2.1.6-RELEASE-x64).

Update Using net use p: \\nas\share * /user:username does work, even though the drive does not appear in Windows Explorer.

4
  • 1
    The usual solution is to enable the SMBv1 protocol. – harrymc Nov 1 '18 at 16:58
  • Please update your question, to include which revision of SMB, you are using. – Ramhound Nov 1 '18 at 17:33
  • @harrymc that option is enabled. I have found that it does work with net use (see updated question). – Bart Friederichs Nov 5 '18 at 9:36
  • @Ramhound I have configured the NAS to use no minimum, and a maximum protocol version of "SMB3". – Bart Friederichs Nov 5 '18 at 9:39
0

You are probably running into the old gotcha that Windows really has two incompatible sets of network shares.

Depending on whether the share was created in Administrator mode, a Windows explorer that is not run in the same mode might not see it.

Try to run the net use command as non-administrator for it to not map the drive against the Administrator profile, so you could see the mapping in a non-administrator Explorer.

1
  • It worked. I threw the net use commands in a startup bat-file and the shares are there now. Still weird that Windows Explorer doesn't even find the server when browsing the network. – Bart Friederichs Nov 5 '18 at 11:10
-1

I have found why this didn't work. I had configured the laptop to use a Microsoft account. This apparently means that plain networking doesn't work as expected.

I removed the Microsoft-connected account and created a simple local account. After this, everything worked as intended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.