1

I'm having a weird problem with one particular keyboard I happen to like. I tend to believe it's not of a physical nature (the keys seem to work in different combinations), but it's definitely a problem with this particular keyboard.

The keyboard is a Dell KB216, with English International layout.

  1. Left Shift + u does not produce anything (not expected), while Right Shift + u produces U (expected).
  2. Right Shift + . does not produce anything (not expected), while Left Shift + . produces > (expected).

The bug is consistent across:

  • Windows 10,
  • Ubuntu 18.04
  • OS X 10.13

Edit: tested across different machines.


The bug is also consistent across multiple keyboard layouts, but I'm only interested in making its native layout work (of course, I wouldn't mind changing for one with a different name and same keys, as long as it would fix the problem - but I'm not going to use a layout with keys positioned elsewhere than what's written on the keys).

Regardless of stroke angle variations, stroke pressure variations or typing speed, none of the two bugged combos produces anything, even when tried multiple times in a row.
I'm fairly sure (99%) it's not a key malfunction (they work smoothly, effortlessly and flawlessly when not used in any of the two bugged combos).

The keyboard is fairly new (somewhere between 6 months and a year) and has been used extensively (I'm a programmer).
As far as I remember, there was no spillage and there was clearly no such incident over the past few days. I'd venture calling it "clean" for its age. The bug started to manifest 2-3 days ago.

Every single one of the four keys (Right Shift, Left Shift, u and .) works normally otherwise, when used alone or in combos (I tested Shift keys solo mode using sticky keys on Windows: they do work). In fact, even the buggy combos work with sticky keys - but I don't want to use Sticky keys! I want them to work normally.

While I could buy a new identical keyboard (I happen to like the keyboard's layout, feel and touch over significantly more expensive ones - and I'm quite picky about my hardware; I also love that it's wired - thus sparing me the trouble of charging and/or replacing batteries), I find the bug quite intriguing and I somehow doubt I'm the only soul on the planet to have experienced it.

Another possible "fix" would be to train myself to always use Right Shift when I want to write U and always use Left Shift when I want to write >, but it's more of a resign than a resolve.


None of the answers or comment suggestions of the following questions helped:

  • Have you had a chance to actually plug another keyboard in just to test? – music2myear Nov 2 '18 at 22:18
  • @music, I plugged this keyboard in different machines (as stated above). All OS'es work normally with other keyboards. I haven't had the chance of testing an keyboard of identical model on any of the above machines, but I tend to believe it's the keyboard that has the bug, because it used to work normally until a couple of days ago. – Andrei Gheorghiu Nov 2 '18 at 22:19
  • Because it's possible all three of those OSes were on the same hardware (VMs), I did not take that to mean you tried the keyboard on different computers. – music2myear Nov 2 '18 at 22:21
  • @music, you asked a fair question and I tried to answer it. On a different note, installing all three OS's on the same machine would be quite a feature and I'm not sure it would be worth the trouble. An interesting thought, though. – Andrei Gheorghiu Nov 2 '18 at 22:22
  • 1
    One word: Hackintosh. Some people will do anything. :) – music2myear Nov 2 '18 at 22:41
1

TL,DR;

Was finally able to determine the cause of the problem and fix it: turns out F7 was locked into pressed position and (at least on this keyboard) the combos above are not recorded when F7 is pressed.


In order to test key strokes sent to the machine, I used DisplayKeyStroke. I figured the least I could do to thank the author for providing it for free was to star their repo and mention it here.
Obviously, any similar app will do.

Once I started the app, I noticed F7 was highlighted. After pressing and releasing it, it no longer showed up as "pressed" and the bug was fixed.

As a thumb rule, whenever combos stop working on a keyboard and you can't find a reasonable explanation for it, it's a good idea to look for a keystroke display application for your OS and test if any key shows up as "pressed".


In the end, it turns out the problem was of mechanical nature - F7 was physically pressed and is acting up a bit, feeling slightly different when used: a tad sticky & stiff; I must have spilled a drop of coffee on it. Having a stuck key was difficult to spot on this keyboard, as it features low profile keys — somewhat similar to laptop keyboards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.