I am having problems with blurry text in some programs, which is very annoying. When I focus the window, it does sharpen the text, but it is still not normal. The weird part is that some part is blurry, while the text below it is normal

Blurry text

enter image description here enter image description here

Some text is blurry while the text below is normal

enter image description here

What can I do to fix this problem? I've tried DPI scaling in Windows properties, changing my scaling in both Windows and Nvidia, I've tried the "fix blurry text" option in Windows, I've tried resetting fonts. I've tried Cleartype. Nothing seems to work. Some programs like Chrome and Intellij are normal, while other have this problem (for example Visual Studio Code here or Github).

Note: It happens on both my 1080P screens and my 1440P screen

EDIT: As suggested, this thread appears to be similar, however, I have disabled intel HD graphics.

  • Try for one troublesome .exe to right-click it > Properties > Change high DPI settings > Override high DPI scaling behavior, and set the drop-box to "System (Enhanced)".
    – harrymc
    Nov 3, 2018 at 16:52
  • As mentioned above, I did all those options
    – Jason
    Nov 3, 2018 at 17:56
  • Try to use other fonts where possible.
    – harrymc
    Nov 3, 2018 at 18:04
  • You say you've changed your resolution in both the Nvidia driver and Windows; this puzzles me, because if you have an LCD monitor, you should always run it in its native resolution. Doing otherwise will cause fuzzy text. If you have a CRT monitor (who does anymore?), is there a power source nearby? If so, can you move the monitor?
    – BillDOe
    Nov 3, 2018 at 18:46
  • 2
    Possible duplicate of RDP to Windows 10 blurry
    – LPChip
    Nov 3, 2018 at 22:15

2 Answers 2

  1. Try updating graphic drivers
  2. There is something called clearType feature in Windows - try activating/deactivating it.
  • I have updated my drivers to the newest. I've tried cleartype, but it unfortunately had no effect
    – Jason
    Nov 4, 2018 at 11:16

Actually this is caused by CMAA (conservative morphological anti aliasing) Feature In Intel's Intergreted GPUs. CMAA improves performance on cost of visual quality. It's not noticeable in games but definitely gives an eyesore in normal applications like visual studio and MS Store.

Here is the simple solution to it :-

Just Go to Intel HD Graphics Control Panel and disable CMAA (under 3D category)

  1. Intel hd graphics control panel

  2. Go to 3d rendering

  3. Disable CMAA

An alternative solution :-

Visual Studio Settings Disable Hardware acceleration in visual studio settings.



You can clearly see the difference between rendering. The text in code editor is also sharp now !


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .