3

I have a Sandisk Ultra 64GB card which works fine.. I used it for a few months and it never had problems

Short story: New files sometimes vanish. Deleted files sometimes reappear, and they also work as if never deleted before

Example 1: I had a full TWRP backup.. I deleted it and created a full new one with a new name... Later I restored it without checking the name and found that I got an old one instead of the latest backup which is impossible right? No, It actually completely ignored the new backup and restored my deleted old backup

Example 2 (TODAY):

  • (Disk appears normal in Disk Manager as exFAT) + (Appears as unallocated in Minitool Partition Wizard)
  • Connected to PC.
  • Formatted as exFAT.
  • (Now it appears as exFAT in all programs)
  • Copied some files (~20GB).
  • Left the PC for ~10m, then came back.
  • (Copied successfully) + (All of the old formatted files are back, all new ones are not there) + (card appears normal in Disk Manager as exFAT and unallocated in MTPW)

Example 3 (today): I also tried formatting it with the format option in phone settings. Tried root apps too. Both successfully did their jobs but the SD returned the original state

In short. My SD Card has mastered time travel...

what are the potential fixes to this situation?

EDIT:

Wiped the entire sd card (fill with zeros) ... MTPW said "process complete" (even though i'm sure it didn't complete) then showed the SD as "Bad disk" until I reconnected it, now it says unallocated.. and it works in file explorer and blabla (original state)

Tried NTFS, exFAT, FAT32 ... Same thing

marked as duplicate by Mokubai Nov 4 '18 at 7:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    As with most storage devices, when they go bad the best fix is to replace them. You shouldn’t trust your data on a device acting up like that. – Appleoddity Nov 3 '18 at 22:45
  • Also note that most failing flash memories show this behaviour, since writing usually fails much sooner than reading. So it is not unusual to see these "back in time" episodes, with erased files that reappear even after formatting, etc. – Igb Nov 3 '18 at 23:40
  • @Appleoddity Thanks guys.. currently contacting sandisk for a replacement.. I hope this goes well – NHKomaiha Nov 7 '18 at 0:12
1

As the many comments already mentioned, if you see troubles like this it would be best to replace the card with a new one, nowadays you get them pretty cheap. Maybe check your bill if you still got warranty?

If you would like to spent some more research time there are a couple of freeare tools available like H2testw and BurnInTest.

Best of luck!

  • I'm currently contacting sandisk for a replacement... (It turns out I have 7 years warranty on this card) – NHKomaiha Nov 6 '18 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.