3

As the title says, I am getting an 'Access Denied' message on multiple websites. The exact message is:

Access Denied
You don't have permission to access "website name" on this server.

The sites that I have discovered so far are homedepot.com, costco.com, and lowes.com. I have been getting the same message on all of the websites, besides the reference codes, which I will list below:

www.costco.com:    Reference #18.15393717.1541289653.5c399d2  
www.lowes.com:     Reference #18.bf273017.1541289827.c064f1  
www.homedepot.com: Reference #18.84273017.1541289848.52e1d8  

My home's router is a Linksys EA9400 AC5000 Tri-Band MU-MIMO Wi-Fi Router, and my family and I have tried this on multiple devices, including a Windows PC, an iPhone, and an iPad, and I tried clearing my cookies on all of them, but it confirmed that it was a router problem, not a device problem.

What should I do to try and fix this problem?

Edit: Just rebooted the router, still not working. I'll upload screenshots as soon as I can.

Edit 2:

DNS:

DNS 1 DNS 2

With WiFi:

With Wifi

Without WiFi:

Without Wifi

ipconfig /all

ipconfig /all

Edit 3: Added another picture to DNS Servers

Edit 4: Added ipconfig /all

Edit 5: homedepot.com works now, but the others still don’t

Edit 6: All of the sites work now, problem solved, I guess? Don't know why the websites were blocked though, that was kind of weird.

  • 2
    Sounds like a DNS issue and/or aggressive ISP content filtering. I would Reset the router to rule it out of the equation. – Ramhound Nov 4 '18 at 0:42
  • 1
    Try setting the IP settings to use a different DNS server than what DHCP may be assigning perhaps. Maybe 8.8.8.8 or 75.75.75.75 or 1.1.1.1. What results do you get when set like that with one of those? If that solves the problem, then consider going into your router and changing the DNS address that is tells DHCP to give to client machines that request an IP from it. – Pimp Juice IT Nov 4 '18 at 1:38
  • 1
    Those DNS servers are really sketchy. The fec0 IPv6 prefix is reserved and has been deprecated since 2004. That IPv4 address looks sketchy too, unless that’s the NAT private subnet for your LAN for some reason (is it?). You need to find out for sure where those addresses are coming from. It could be some kind of adware/malware that’s acting as a fake DHCP server and DNS server on your local network in order to keep your systems compromised or serve ads. – Spiff Nov 4 '18 at 1:41
  • 2
    It's not uncommon to have cross-domain POST attack change settings in your router if you leave it with the manufacturer password. You probably got your router's DNS settings poisoned with a malicious server that will attempt to prevent you from reaching some websites, that usually include websites where you try to find help for your problem. I advise you to reset the router settings to factory defaults and set it up anew, and for your own sake use a password that doesn't suck. – Havenard Nov 4 '18 at 1:49
  • 1
    Did you configure that IPv4 address yourself? – HazardousGlitch Nov 4 '18 at 1:53
0

Solved itself on November 6th, don't know what happened here but all's well now!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.