0

I'm running ubuntu 18.10 as lxc-container at proxmox 5.2 on my homeserver. I want to automatically mount a cifs share which i added to /etc/fstab file:

//fileserver.lan/Serien /srv/storage/serien cifs defaults,uid=109,gid=116,noauto,x-systemd.automount,x-systemd.requires=network-online.target,user=plex,username=plex,password=plex 0 0

running

systemctl daemon-reload

automatically generates a srv-storage-serien.automount and srv-storage-serien.mount at /run/systemd/generator directory but after reboot the cifs share is not mounted. Instead I only see the following line in journalctl(no additional information provided):

Starting of srv-storage-serien.automount not supported.

which is also what systemctl status gives me:

root@plex: systemctl status srv-storage-serien.automount
* srv-storage-serien.automount
   Loaded: loaded (/etc/fstab; generated)
   Active: inactive (dead)
    Where: /srv/storage/serien
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)

Nov 04 19:49:22 plex systemd[1]: Starting of srv-storage-serien.automount not supported.

Manually executing

systemctl start srv-storage-serien.mount

OR

mount /srv/storage/serien

works fine. just the automount is not supported for some reason. Am i missing something?

I also have some Debian 9 non-LXC installations on my proxmox host which use the same mounting settings which do not have this issue.

2

.automount units rely on the kernel's autofs module. Currently (as of Linux 4.19), autofs code still does not support namespaces – so if containers were allowed to use it, they could mount anything anywhere, including on the host and inside any other container. Therefore autofs usage is limited to root on the host namespace only.

  • whats the best way to mount the cifs share on boot then? i cannot systemctl enable srv-storage-serien.mount because it is a generated one. I can start via crontab's @reboot: systemctl start srv-storage-serien.mount – A.Winnen Nov 4 '18 at 23:04
  • Remove the noauto option from its fstab entry? – grawity Nov 4 '18 at 23:06
  • does it still wait for the x-systemd.requires target then? I tried with auto but the share was not mounted. – A.Winnen Nov 5 '18 at 10:45

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.