A private connection to www.google.co.in can't be established because your computer's date and time (Friday, January 1, 2010 at 12:04:46 AM) are incorrect. How can I correct the clock permanently.


Open the BIOS or UEFI settings and adjust there.

If the problem persists after a reboot then the motherboard's battery needs to be replaced. For desktop computers it's typically a CR2032.

  • 1
    Considering the date it shows is about 7 years in the past, and the life of those batteries is about 5 years, that its the battery is plausible. I'd also add that its not worth putting off a replacement - those batteries can leak, so if you think the battery is the issue, its worth removing pending replacement. – Journeyman Geek Nov 5 '18 at 5:29

It may be good enough to set it to (approximately) the correct time from the operating system.  If you are using NTP, it should get into sync and stay in sync after that.

If you use NTP, and yet the time drifts, you have a problem.

The exact method of setting the time is different on different operating systems.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.