1

Normally, when I create a shurtcut in Google Chrome, it opens just the site without address, menu and tab bar. But now, when I open my newly created shortcut for Google Calendar, it opens the calendar just fine, but also with another "New" tab and therefore with a usual browser window (including address, menu and tab bar).

Did I do something wrong or is this perhaps even a bug?


Preferred outcome when clicking on shortcut:

enter image description here

Actual outcome when clicking on shortcut:

enter image description here


Shortcut details:

  • Target: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory=Default --app-id=biikooaipklhpkkjkeijimjicofaknlo
  • Run in: "C:\Program Files (x86)\Google\Chrome\Application"
  • Maybe there is something wrong in the Windows Registry? – Cyman Nov 5 '18 at 10:28
1

To get chrome to open a "tab/navigation"-less window with a shortcut. Use -app=url

  1. Create a new shortcut to chrome
  2. In the target field, after chrome, add -app=your-url-you-want

When running shortcut, it should start up a borderless window, just as it did earlier when you could click the checkbox for a frameless window when you made your shortcut.

I did a shortcut to test just now (url taken from a normal browser window), with this as target:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -app="https://calendar.google.com/calendar/r?tab=mc"

I'm not sure how to get it to work when you already have an --app-id

But if you can get an url, this method should work.

  • Awesome, you are a genious! ;) But the strange thing is, when I look at older shortcuts for Google Contacts, Inbox, etc - they look the same (with app-id) but work nevertheless (i.e. opening only one tab with a frameless window) - any idea why that is? – Cyman Nov 7 '18 at 17:12
  • I don't know. I have noticed a flaw with what I wrote above since I wrote it. If you pin it to the taskbar, and use that as a shortcut to open a window, It will open another icon on the taskbar, not "use the shortcut". – Frank H Nov 9 '18 at 7:29
  • Installed a few computers the other day, and it seems to have started to work as it used to. In chrome, click the three dots, more tools, create shortcut, and then click the little box about windowed mode. Should create a borderless window, that you can place in the taskbar. – Frank H Mar 26 at 12:52
  • Hi Frank, yes, you are right - it is the little checkbox with the windowed mode that makes the difference! Thanks :) – Cyman Mar 31 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.