0

I have 1000 servers to work with, but today all the server passwords expired.  I regularly use plink (PuTTY) to connect with 1000 servers.  Today I got error “Password change required but no TTY available”.

Then I have enabled TTY by enabling plink -ssh -t and tried to attempt to change password with below command

m:\plink>echo.password1 & echo.password2 & echo.password2 | plink -ssh -t username@13NB:xx0:320:112:0:0:0:XY -pw password1

but passwd: Authentication token manipulation error occured.

While doing manually (human inputs on Windows-cli) everything works fine, but while doing automatically something went wrong.

When attempting another method:

m:\plink>plink -ssh -t username@13NB:xx0:320:112:0:0:0:XY -pw password1 < credential.txt

credential.txt contains 3 lines: password1 password2 password2

but till password1 (current unix password) it is success after that the command unable to take password 2 and prompting newpassword.

Please provide a good solution.

1

Windows CMD is interpreting your command line as

m:\plink>echo.password1
m:\plink>echo.password2
m:\plink>echo.password2 | plink …

To get all three passwords sent to the pipe, you need to group the echo commands:

m:\plink>(echo.password1 & echo.password2 & echo.password2) | plink …
  • i have tried the above with closed brackets.. but still same issue.. passwd: Authentication token manipulation error occured – Python Spark Nov 6 '18 at 4:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.