0

Now I'm looking for more information why do my network file sharing doesn't work properly even if I made router to be part of LAN. I'll explain all my possible changes I can remember. I chosen to merge both of devices into same subnet.


Wiring

Modem has DSL connected so internet is available.

PC1 <-LAN-> Modem <-LAN-> Router <-LAN-> PC2


Modem

LAN IP: 192.168.1.1

Subnet: 255.255.255.0

DHCP: ON (Range: 192.168.1.2 - 192.168.1.-199)


Router

LAN IP: 192.168.1.200

Subnet: 255.255.255.0

DHCP: ON (Range: 192.168.1.211 - 192.168.1.254)

I want DHCP it to be enabled, because only 200-210 ending addresses will be static ones. Rest of users are friends or such.


PC1 (Connected to Modem)

IP: 192.168.1.204

Subnet: 255.255.255.0

Gateway: 192.168.1.1


PC2 (Connected to Router)

IP: 192.168.1.205

Subnet: 255.255.255.0

Gateway: 192.168.1.1


All what I have noticed

  • Router is pure-NAT router and NAT cannot be turned off for some reason. There's no such a option. (TP-Link WR940N)

  • I see the both of devices on explorer's Network section (PC1, PC2), but they can only connect to themselves, but not each others.

  • Both are on Private network profile and both has folder shared which has permissions to "Everyone - read & write"

  • Both have access to internet too.

  • Logging into Modem's Administrator Web-UI I can see both of devices as clients in client list: (PC1 - 192.168.1.205, PC2 - 192.168.1.206)

  • Explorer says from PC1: "Windows cannot access... Problem can be in network", but I cannot find any problems in my configurations. Private network file and printer sharing is turned on.

Many people may think why do I have router between modem and PC2. Actual reason is that I like to play with devices and I want to learn much more about them.

  • Why is it a requirement to have DHCP be running on both devices? The TP-Link's DHCP server will by default tell clients to use the TP-Link as their gateway, which is certainly not what you want in this setup. – grawity Nov 5 '18 at 13:47
  • (And while this suggestion is mostly off topic... for learning, get a Mikrotik router. They're amazingly flexible considering the price – no "NAT cannot be turned off" nonsense.) – grawity Nov 5 '18 at 13:49
  • I'm interested about router you mentioned, thank you. Actually now I turned the DHCP off on TP-Link. It makes PC2 able to connect to PC1, but not mutual. – Epz Nov 5 '18 at 14:13
  • Have you connected the router to the modem as LAN-to-LAN? – harrymc Nov 5 '18 at 15:27
  • Yes. It's connected like mentioned above. Seems that we got a little bit forward with Wireshark. – Epz Nov 5 '18 at 15:33
0

Router is pure-NAT router and NAT cannot be turned off for some reason. There's no such a option. (TP-Link WR940N)

Fortunately, that's not important as long as no devices actually use 192.168.1.200 as their gateway. That's the only way they'd reach the "router" part of the device – so as long as they don't, all data simply short-circuits through the built-in Ethernet switch chip, and the "router" CPU just sits there doing nothing.

The gateway is never used for same-subnet communications, anyway. As long as both computers know the correct netmask, they will send packets directly to each other.

So on the whole, your configuration looks like it should work perfectly fine. Since it doesn't, you have at least two things to check:

  1. Make sure the firewall rules are right. Open wf.msc, the firewall rules editor. Under the "Incoming" section make sure the necessary "File Sharing" rules are enabled. (For access by \\IP, at minimum SMB-over-TCP via port 445 must be allowed.)

  2. Make sure PC1 and PC2 have learned each other's correct MAC address via ARP. On Windows, you can run arp -a to see the ARP cache.

  3. Make sure packets sent by PC1 are received by PC2, and vice versa. Install Wireshark on both systems, and start a capture on the Ethernet adapter.

    You can set a capture filter such as arp or icmp or udp or (tcp port 445) or a display filter such as arp || icmp || udp || tcp.port == 445 to filter out irrelevant web traffic. (Capture filters are set before starting the capture; display filters are set while capture is running. Their syntaxes are different.)

    The capture is unaffected by firewall settings. If a packet is coming in, but the OS isn't reacting to it, that usually indicates a problem with the firewall's "incoming" rules.

  • Sorry I have to reform my comment... SRVSVC says NetShareEnumAll response, Error: WERR_ACCESS_DENIED – Epz Nov 5 '18 at 15:21
  • There are share-level permissions and there are file-level permissions. Both must allow acccess. (And of course you must be allowed to 'log in' to the fileserver in the first place – for example the account's password must not be blank.) – grawity Nov 5 '18 at 15:21
  • Does NetShareEnumAll happen before authentication or afterwards? I somewhat suspect some of the "server's" security settings might be wonky, but I have no idea which. – grawity Nov 5 '18 at 15:22
  • Happens just before this. Shows "NetShareEnumAll request" which comes from LAN machine that is trying to connect. File and printer share is turned on in private network profile which is active. But I think I can mark your answer as solution, because it seems that the problem just hopped to permission errors. – Epz Nov 5 '18 at 15:32
  • @Epz Can you run secpol.msc and check whether "Disallow anonymous enumeration of shares" under "Security options" is disabled or not? – grawity Nov 6 '18 at 6:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.