0

So fedora 29 is out.

cat /proc/filesystems

no overlay2 again. So this is the most most cutting edge distro from RH, which propagates docker heavily, but I'm still not able to use what's normal for docker and available elsewhere for years. Or am I missing something how to use it? I cannot find any how-to. In every documentation I see the RH is not mentioned as supporting overlay2 file system, and expects us to use device mapper or vfs.

So:

a) is it somehow possible to use overlay storage driver in fedora or not?

b) if not, could you recommend some other distro to someone who is used to Fedora distro?

  • 1
    What's your question, actually? What problem would you like us to help you solve? – gronostaj Nov 6 '18 at 11:03
  • I would like to use overlay2 fs storage driver in fedora 29, instead of available vfs or devicemapper drivers. But overlay2 seems to be not present after installation, and I cannot see a way how to install it. – Martin Mucha Nov 6 '18 at 11:26
  • 1
    Then please edit your post, remove the rant part and focus on the problem. Make sure to include results of your research, what you've already tried etc. – gronostaj Nov 6 '18 at 11:28
  • Does the Docker documents page answer this question? Being the most cutting edge != supporting all of the things. Fedora brings leading edge innovation. It doesn't meant it will support every new thing available. – DrZoo Nov 8 '18 at 17:10
  • No, actually. It's pretty misleading instead. a) it says, that overlay2 is in experimental phase in fedora, and it's used by default b) suggestion how to enable it will lead to failure to start of docker. So no, I'd consider Docker documentation not doing it's job. I still have no idea what's the state of overlay2 storage driver in fedora 29 or 28. I'm just positive, that it's used by default. – Martin Mucha Nov 8 '18 at 20:33
2

The contents of /proc/filesystems only tells you which filesystems are currently present and the overlay filesystem is provided as a module so you will need to load it before it appears.

You should be able to load it with modprobe overlay but I suspect it will also load automatically if you actually try and mount an overlay filesystem.

Note that overlay2 is the name of a docker storage driver (which replaces the older overlay storage driver) which uses the overlay filesystem and not actually the name of a separate filesystem.

  • according to docs.docker.com/storage/storagedriver/overlayfs-driver/… one should use "{"storage-driver": "overlay2"}" in file /etc/docker/daemon.json and restart the docker. If I do so in fedora 29, even after I did modprobe as you shown, I'm getting: unable to configure the Docker daemon with file /etc/docker/daemon.json: the following directives are specified both as a flag and in the configuration file: storage-driver: (from flag: overlay2, from file: overlay2) – Martin Mucha Nov 6 '18 at 15:58
  • 1
    That sounds like you have tried to specify the driver twice - once on the command line and once in the configuration file and apparently docker doesn't like that even when they are the same. – TomH Nov 6 '18 at 16:53
  • TomH: correct! I checked systemd unit files, and there in /etc/sysconfig/docker-storage is specified DOCKER_STORAGE_OPTIONS=--storage-driver overlay2 ~~~ so it seems, that only docker documentation is outdated + I was using wrong commands to verify overlay2 being in use. Can you recommend correct way how to verify overlay2 being in use? Thanks! – Martin Mucha Nov 6 '18 at 19:39
  • Not really - docker is not something I know much about. – TomH Nov 6 '18 at 23:05
  • @MartinMucha See stackoverflow.com/questions/20810555/… – Robin Green Nov 17 '18 at 9:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.