2

In order to type a literal date into an Excel cell, I currently have to do it in the American format (mm/dd/yyyy). This is unacceptable.

How can I have it such that Excel will correctly recognise dates in the standard dd/mm/yyyy format when typing directly into cells?

Note: I am not asking how to use the "cell format" features of Excel. That is easy enough. I want to be able to directly input international dd/mm/yyyy dates into cells and have them register correctly, regardless of formatting.

3
  • Check your regional and language settings. – Mark Fitzgerald Nov 6 '18 at 11:59
  • make it an answer and i'll accept it – TheIronKnuckle Nov 6 '18 at 12:56
  • @TheIronKnuckle - while you're at it, the only "universally accepted standard" date format is ISO-8601, which is yyyy-mm-dd – Hannah Vernon Nov 6 '18 at 14:22
4

Excel follows the Region and Language settings of Windows.

In Windows 10 : Settings > Time & language > Region & language. You can either take the default values, or you can fine-tune further in Additional date, time, and regional settings (date, time, number settings etc.)

2
  • Does that mean that I can't work on 2 files with dates in different formats at the same time? – Federico Nafria Jul 20 '20 at 21:16
  • 1
    @FedericoNafria Sorry for the very late reply. To my knowledge, you cannot input 01/02 in two files, and expecting that in the first file it means Feb 1st and in the other file Jan 2nd. Please note that this is about writing directly in cells. You can have cells with date values (which Excel stores as integers), and display them differently according to how you format the cells in Excel. – Peter K. Jan 27 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.