6

I have installed and am using 1Password browser plugin. This works by adding a small icon in the right end of usernames in form logins, which when clicked on brings up a dropdown with saved login details.

However, Chrome has, since a recent version, began to trump my setting for storing passwords in chrome by remembering the usernames I use, and when I click in the username field, it brings up a dropdown with remembered usernames, overshadowing the dropdown that 1Password brings.

Here's a screenshot from my TeamCity server.

chrome suggesting username

If I hover over the username in the dropdown provided by Chrome and hit Shift+Delete, the username is gone, but it will reappear once I've successfully logged back in.

The settings are as follows:

settings for saving passwords

Now, clearly the settings says to offer to save passwords, but there's no corresponding setting for asking it to stop remembering username.

Is there anything I can configure that would stop this behavior?

3
  • StackOverflow's stackoverflow.com/questions/15738259/disabling-chrome-autofill is answering your question. – moutonjr Nov 7 '18 at 9:12
  • I'm hoping that isn't the answer because, as I said, this seems to be a rather recent update to Chrome, it didn't use to do this, and it does this on all sites, I don't want to go about hacking the html of every site that I use where I experience this using something like greasemonkey or whatnot. The problem isn't with sites I control, the problem is with all sites used through Chrome. – Lasse V. Karlsen Nov 7 '18 at 9:39
  • ... BUT! It got me on the right track, searching for autofill got me to autofilling addresses. Disabling this (because I fill this from 1Password as well) disabled this feature. – Lasse V. Karlsen Nov 7 '18 at 9:42
8

The correct setting was "Addresses and more", which has this description:

Includes information like phone numbers, email addresses, and shipping addresses

I didn't find this because I was searching the settings for "username", but this probably falls under "and more".

Disabling this removed the problem. This is fine by me as I also fill addresses from 1Password.

2
  • Thanks for this. I consider usernames somewhat confidential too, so I think this was not a great automated move by the Chrome team. – user2428107 Mar 22 '19 at 4:47
  • You can turn it off, but the username is still saved in your (local? cloud?) account. If you turn it back on, you'll see your username has been preserved. Still no clue how to remove the sensitive data. – A.K. Sep 25 '19 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.