3

My System: I have an I7-4790k cpu and a fast connection (low latency/ping 33 e.g. to amazon.de, enough traffic bandwidth 32 Mbps). I'm using Firefox 63 stable which uses all my cores.

Problem: Still, when I load an page like www.mediamarkt.de it doesn't load as fast as, bam. What is the problem, why isn't it faster? You can see in the picture, that "Aktuelle topseller" shift later to the correct position and later the text font is changed.

Why doesn't this happen at once?

Possible explanation? Is my CPU not fast enough, does Firefox load resources sequentially?

enter image description here

Edit Edit: I will mark this problem now as solved, because the original problem was solved. Optimization is another topic.

4
  • It has been several days since we heard from you. Did you have any lingering questions?
    – Run5k
    Commented Nov 28, 2018 at 21:11
  • @Run5k I'm not quite sure, if "no proxy" solved the problem. I'm waiting for Firefox 64 to see, if this solves the problem. It is released on 11. december. Commented Nov 30, 2018 at 13:11
  • @SearchSpace if you take a look at the update within my answer, the latest Firefox patch to version 63.0.3 should have eliminated the problem. It did on the laptop that I utilize for testing purposes.
    – Run5k
    Commented Nov 30, 2018 at 13:34
  • @Run5k Ah, I didn't see that. Nice.I think it's a bit better. But I now assume that my problem is network bound. When I use F12 and look at the network analysis, it seems that my Firefox updates the Website in time with the frequests. With http/2 it should be better and I didn't found a setting which could enhance this (e.g. like pipelining in the early days). Prefetching astonishingly didn't make better side loads either (or i missconfigured??). Commented Nov 30, 2018 at 17:29

1 Answer 1

5

I encountered the exact same problem after installing Firefox 63 on two Windows 10 machines residing on my home network, and my online research found the following:

Firefox 63 is slow at loading new pages

Found the reason for this behavior. For some reason the new version puts the proxy settings so that the "Auto-detect proxy settings for this network" is enabled. This makes it so that every page load it tries to first find a proxy, which takes seconds, and after that loads the page. Switched the setting back to No Proxy and everything is nice and fast again.

This seemed to be confirmed in a pair of official "bugzilla" reports:

Version 63 very slow performance, proxy set to "use system default" - fixed if set to "no proxy"

Firefox checks to determine proxy settings on every request - RESOLVED FIXED in Firefox 64

As a result, their recommended fix action is as follows:

  1. Within Firefox, navigate to the about:preferences page
  2. In the default General section view, scroll to the bottom to find the Network Settings area
  3. Click on the Settings... button
  4. In the subsequent window, select the radio button to modify the settings under Configure Proxy Access to the Internet to choose No proxy

    Connection Settings

However, although this solution apparently worked for several people, in my personal experience the problem persisted even after I changed my settings to No proxy. One of the Mozilla contributors recommended installing the Firefox 64 "Nightly" version to see if that eliminated the issue and it did for some users, but I'm not really a big fan of Beta software on my primary computers.

As an alternate solution, I uninstalled Firefox 63 on one of my computers, installed Firefox 60.3.0 ESR, and that alleviated the problem. Web page navigation and downloads were as fast as they were in Firefox 62. Also, please remember that a transition like this one is relatively painless, because your Firefox personal data is preserved in another location.

I left Firefox 63.0.1 installed on my secondary computer for ongoing testing purposes. When Firefox 64 is released to the general public in December, I will double-check to ensure that the problem has been alleviated.


Update

Mozilla has apparently addressed this issue in their latest update that increments the mainstream iteration of Firefox to version 63.0.3:

Firefox version 63.0.3

6
  • I tried this solution (no proxy), and I have the impression, that it is now slightly faster. Thank you. (I won't single"accept" this answer yet, though i upvoted it, because I'm searching for as many solutions as there are to get firefox page load faster :)) I also tried setting network.tcp.tcp_fastopen_enable to true. I think this also increased page load performance on some sites (less tcp overhead). Can you confirm that as well? Commented Nov 7, 2018 at 20:19
  • @SearchSpace the No proxy solution, or installing Firefox 60 ESR, instead?
    – Run5k
    Commented Nov 7, 2018 at 20:22
  • No, you don't get notified when someone edits a comment... only when they are posted. That being said, as I mentioned within my answer, the No proxy solution didn't actually work for me, and there is a known issued with that particular version of Firefox. That's why I ultimately decided to drop back to the ESR version of the browser, and my downloads started working normally again. Prior to that, every-other-download would fail.
    – Run5k
    Commented Nov 7, 2018 at 20:25
  • Ah ok, thanks. First comment was edited. Btw. as I understand it: There are less chances to make load faster with more connections, because due to http2 the idea seems to be, to just have one connection, which transfers all data. I couldn't find out yet, if there are options to instruct firefox to load all elements parallely in this one connection (or if this is by default). Btw. do you have an powerful processor, does firefox utilize all your cores? Commented Nov 7, 2018 at 20:30
  • Actually, both my laptop and desktop have mediocre hardware specs: an Intel quad-core i7 with 8 GB of RAM. Nothing special.
    – Run5k
    Commented Nov 7, 2018 at 20:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .