3

Since I've moved to a new apartment a few months ago and changed my I ISP (the one shared with other apartments in building - same router) I experience internet drops (ethernet) every ten minutes, quite exactly.

There seems to be some variation, but here's an example (I deduce this from when I ping 8.8.8.8):

4:10:27 pm (First) Drop.
4:11:54 pm Reconnect (after 87s; normally between 0.5 and 4 min).
4:21:09 pm Drop (after uptime of 555s or 9min 15s).
4:25:04 pm Reconnect (after 235s).
4:34:15 pm Drop (after uptime of 555s again!).
etc.

(It is possible that the drop time is slightly earlier...)

The uptime interval is quite constant (between 540 and 590), while the downtime varies more (between 0.5 and 4 mins). During these drops I cannot browse or receive emails in my mail program, etc, while the router itself is reachable at all times; the connection monitor states a "green" connection.

Other tenants know this problem too, but it doesn't seem to be that grave with them (drops less often, if any at all, faster connection time?).

I've had a look at our router:

  • IPs are set to static, so my laptop gets the same IP every time it connects. I therefore rule out IP interference between the different devices.
  • DHCP lease is set to 10 days. So a too short DHCP lease time can also be ruled out...
  • I restarted the router, nothing changed. (I am not allowed to reset, because the landlord has his phone line through said router.)

What could be the problem? Is it more likely my laptop (never a drop at the old apartment...), the router or the ISP?

My setup:

+Device+                +Connection type to next device+

Street (ISP)            via fibre-optic
to Modem                via Ethernet Cable
to Router               via Ethernet Cable (=EC)
to "public" Switch      via EC        (also to other tenants wall ports and from there to their routers and devices [directly and over those routers] probably via EC or WiFi)
to Wall port in my room via EC
to my switch            via EC
(to Dock*               via EC)
to my Laptop            via EC (or* USB 2.0).

*sometimes I use a USB Docking Station [Sabrent DS-RICA], but the problem stays the same, whether I do or don't.
  • Modem: DKT Comega 97601 FTTH Gateway (on its bottom: "next gen snmp, ftth-node, wan [?!], no VOIP, no CATV")

  • Router: FRITZ!Box Fon WLAN 7390, only Ethernet activated and "DSL deactivated" (no DSL because fibre-opic to ethernet).

  • Laptop: MacBook Pro 13'' Early 2011 with OS X 10.11 El Capitan.

EDIT:

!!Only entries 3 and 5 (bold first sentences) might be relevant; skip rest & go to UPDATE below!!

  1. There seems to be a difference where I use my laptop docking station or plug in the ethernet cable directly into my laptop: With the latter setup the reconnection time is shorter and more constant, around 13 seconds instead of 0.5 up to 4 minutes... But the drops still occur and last for a similar amount of time with both setups.

  2. Bringing the router time and laptop time in line with each other (laptop gets its time now from router; see below) did not solve the problem.

  3. The router's public IP remains the same before and after the drops. (The same goes for the internal IP of my laptop [since it's static].)

  4. The problem also occurs when I'm the only device connected to the router (apart from a printer and a second FRITZ!Box connected to the first; the second router and the printer both have static IPs on the first router).

  5. During a drop Wireshark registers many TCP Retransmission entries (black bars).

    When I run Wireshark on the ethernet connection, there are no DHCP processes after a drop (apart from DHCP v6: Solicit XID). When I plug out and plug in my ethernet cable (out of and into the docking station), Wireshark registers the following DHCP processes (not quite Discover-Request-Offer-Acknowledgement):

    +Packet No.+  +Time+  +Info+
    
    7             14      DHCP Request
    38            15      DHCP Request
    48            18      DHCP Request
    59            22      DHCP Discover
    65            24      DHCP Discover
    68            26      DHCP Discover
    73            31      DHCP Discover
    74            31      DHCP Offer (sends static, expected IP)
    76            32      DHCP Request
    77            33      DHCP Request
    80            35      DHCP Request
    81            35      DHCP Acknowledgement
    

    When the ethernet cable is plugged into the laptop directly this process is (way faster and less messy):

    +Packet No.+  +Time+  +Info+
    
    5             0       DHCP Request
    46            1       DHCP Request
    47            1       DHCP Acknowledgement
    
  6. The "public" switch has 8 ethernet ports, port 1 being the port where the signal enters, port 4 being the port which delivers my signal (to a wall port in the router room). Switching the latter ethernet cable to another port (e.g. port 5) or connecting my laptop directly to such a port does not solve the problem. So the switch seems to work fine (see UPDATE below). Connecting to the router directly did not solve the problem either (see UPDATE below). I believe that all other tenants, except me, use another router between the FRITZ!Box router (or rather between their wall port) and their devices. Could not using an additional router be the problem? (Probably no; see UPDATE below.)

  7. Information about the Router: Router internal log does not show anything when my drops occur; no unexpected log entries at all. Firmware FRITZ!OS 06.85, up to date. Self-Diagnosis ok. NetBIOS denial and Teredo denial active. Router firewall off. IPv6 deactivated, IPv4 only. Only the ports 443 (HTTPS), 5060 (Phone, SIP), 7078-7109 (Phone, RTP) and 8089 (TR069) are open. All other ports closed; I can confirm this by port scans from the outside. E.g. port 80 is not open. Should port 80 be open? (Maybe does not matter?!) Additionally I am going to write an email to the FRITZ!Box support (pending, see below, UPDATE2).

  8. The landlord says that he experiences phone connection drops (he's connected via ethernet cable to the router („FON“); maybe VOIP?) from time to time. Also his internet connection drops the same way (see UPDATE below), but he notices this not as often, since he browses not that frequent.He says that both problems started to occur when the building was connected to the new fibre-optic line of the city (before probably connected via phone line). Could this phone trouble be connected to my problem? (Probably yes; see UPDATE below.) Could my problem have something to do with the fibre-optic? (Probably no; see UPDATE below.)

  9. Information about the connection at my old apartment: At the previous apartment I’ve had never any problems connecting and staying connected. First setup there was Wall port (Antenna socket [≠ Satellite])-->Modem (probably DSL?)-->Netgear Router-->Laptop, the (second) and most recent setup there was Wall port (Antenna; now same port as TV)-->ISP brand Modem-Router (?) (Phone cables also went in there)-->Laptop, same ISP with either setup, but a different one from now. I plugged in the ethernet cable and it worked instantly and flawlessly...

UPDATE!!

Yesterday evening I've connected to the router directly with an ethernet cable, but the same problem occurred. Then I had the idea of plugging the very same cable into the modem: No more internet drops, flawless browsing!! (Just some observations: A) I couldn't reach the router from the modem [naturally, since I'm not in the router network]. B) I had an IPv6 and different public IPv4 [same reason]. C) Wireshark registered constantly ARP protocol "Who has... [fill in IP]" entries from the origin "BrocadeC_1c:14:00", nothing else, but it worked. Is C) normal?)

This is ok and would be a workaround, but I am not satisfied yet: That router has to work; especially since I had the chance to install Wireshark on my landlords computer with is also connected to the FRITZ!Box router (via the same public switch as I am) and can confirm now, that the problem also occurs on other devices (also on mobile devices connected to this FRITZ!Box via another WLAN router [tested via ping]).

From the information in the two paragraphs above, I conclude, that the problem is with the router. (ISP and modem ruled out by directly connecting to the modem, my laptop [and all other attached devices] ruled out due to Wireshark test on second laptop, Switch and cables ruled out by directly connecting to the router.) I therefore reset (wiped) the routers configuration (back to factory settings) and directly connected to the router via ethernet cable: Problem gone. Unfortunately, I had to reconfigure the router, because my landlords phone goes through the router. Since I didn't dare to do this myself, I uploaded the old configuration file to the router: Problem occurs again... So the problem lies within that specific configuration?!

Three questions (and one minor one in the first paragraph of this update):

1. Is my conclusion correct?

2. What would you recommend me to do?

3. Are my landlords phone problems (EDIT 8 above) connected to this?

UPDATE 2

I tried reconfiguring (manually and automatic): As soon as I change even the tiniest detail of the FRITZ!Box configuration (e.g. turn off WLAN or add phone number) on the reset FRITZ!Box (where there is no problem), the problem reoccurs... It's so strange. I'm nearly done for: I've written to the FRITZ!Box support now and am waiting for their answer...

  • I know this is going to sound weird, but check the time on all devices, and make sure it is set correctly. – LPChip Nov 7 '18 at 14:42
  • @LPChip Thank you for your answer. You mean the system time? I'll try, but there are quite a lot devices, including printers... :S – CJLM Nov 7 '18 at 14:53
  • 2
    Does your public IP address change after the drops? – DavidPostill Nov 7 '18 at 17:11
  • 1
    Yes, the problem is in the specific configuration. Sit down with your landlord, configure it manually for what the landlord needs. If the problem occurs again, start over, test at each step if the problem occurs, so you can pin down the configuration step that causes it. BTW, you can also write your own answer to your question (and accept it), and detailed description of what you did may be helpful to others. Comments are not guaranteed to be permanent. – dirkt Nov 10 '18 at 8:51
  • 1
    @dirkt and @ all: Well I tried and tried: As soon as I change even the tiniest detail of the FRITZ!Box configuration on the reset FRITZ!Box (where there is no problem), the problem reoccurs... It's so illogical. I've written to the FRITZ!Box support and am waiting for their answer... – CJLM Nov 13 '18 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.