I have exported a file from Adobe Illustrator as .dxf file in several ways - basically trying all the combinations of the export settings such as the version of the dxf file, or whether to modify pathes in order to preserve looks, etc. In every way, a dxf file is created, which I can view with QCAD. But Inkscape tells me this when I try to open the file:

1 ABSCHNITT der POLYLINIE aufgetaucht und ignoriert. Bitte versuchen Sie diese mit QCad in ein Version 13 Format zu konvertieren.

Roughly translated:

1 SECTION of the POLYLINE appeared and ignored. Please try converting them with QCad in a Version 13 Format.

(sometimes it said more than one)

I proceeded to try exactly that, but still, Inkscape gives me the same message. I also tried using an online converter, and taking various filetypes as intermediate steps, but that didn't work out either - always resulting in this same error message.

I have tried, in Illustrator, to turn everything into pathes before exporting - also without success. exporting as path to dxf

I have also tried creating a new file (and exporting that as path and directly) - as simple as it gets - and the same problem is still happening. However, though it is happening with most of my dxf files, some files with only in them pathes work.

How can I export or convert my Adobe Illustrator .ai file to a .dxf file which Inkscape can read?

(The reason why I want this, is because I am actually trying to figure out why a very different application does not work, and since I stumbled upon this issue, I think they may or may not be connected)

These are my import settings for inkscape, but the message appears even if I untick the ticked box: enter image description here

It may or may not be relevant that using Illustrator's Text to Path functionality causes the resulting dxf file to fill the holes e.g. in the character "D". Compare: not pathed pathed

I am using illustrator CS6 Version 16.0.0 (64-bit) and Inkscape 0.91 The problematic files are not only problematic on one machine, but I have only tried on win10 so far.

The font does not seem to be the problem. The example file uses Myriad Pro, but it also happens with Arial.

up vote 3 down vote accepted

Inkscape dxf import is broken and freaks out when meeting POLYLINE and other entities. I have found two Inkscape bug reports dealing with it :

The workarounds given in both threads are summarized here :

  • A workaround is to export a PDF from Inventor and import that into Inkscape. You need to un-group it a few times in order to access individual paths.
  • Converting to Release 13 format acceptable for Inkscape using QCad is only possible in the paid version. However, LibreCad, a fork of QCad, can also do the conversion.
  • Exporting as PDF from *Illustrator and importing that worked. Thanks! – lucidbrot Nov 11 at 10:41

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.