I recently upgraded my PC and swapped out my CPU/mobo/RAM in the process.
Now I have a

  • Ryzen 3 1300x processor,
  • MSI B350M GAMING PRO motherboard and
  • 2x8GB G.SKILL Ripjaws V 2400Mhz RAM,

running on a Windows 10 Pro machine.

For some reason, even though I have both sticks installed and recognized in the system (I have 16GB of available RAM), it is marking them as Single Channel in CPU-Z. I don't see any settings in the BIOS to enable "Dual-Channel" mode for my RAM so I'm not sure how to fix this.

As far as I know, Single-Channel vs Dual-Channel RAM has a big impact on Ryzen performance, because of the architecture behind the Infinity Fabric, so I am looking to fix this ASAP.

How can I fix this?

closed as too broad by Ramhound, PeterH, Toto, fixer1234, Anaksunaman Nov 15 at 10:53

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

A similar question is here at StackOverflow.

The WMI command

wmic memorychip get InterleavePosition

will tell you what the memory channel situation is.

You can check the motherboard manual to see which RAM slots are related. Perhaps 1 and 2 should be populated first, perhaps 1 and 3. It varies by manufacturer.

  • There are only 2 available slots on the motherboard. – lonewaft Nov 8 at 21:49
  • Reading the Manual of your Motherboard you only have two(!) DIMM slots: DIMMA1 and DIMMB1. Unfortunately, I do not know why only one of them is recognized. – zx485 Nov 8 at 21:55
  • @zx485 Both are recognized, the author indicates it’s just running in single channel mode, hence the author’s question – Ramhound Nov 9 at 0:58

http://download.msi.com/archive/mnu_exe/M7A39v1.4.zip contains your manual, and a review of it showed no option to enable or disable Dual Channel memory. Therefore, if here's no way to turn it on/off, the memory modules are the likely cause. If they are not identical, you won't get Dual Channel mode, so check both of them, and replace one with a module identical to the module in the PC.

Not the answer you're looking for? Browse other questions tagged or ask your own question.