1

I realized that the shortcuts ctrl+shift+c/v doesn't work anymore in gnome-terminal, then I went to the keyboard settings, I tried to set a shortcut ctrl+shift+<any character> and didn't work, it is just like if the shift key was not held. I decide to check with the showkey command:

showkey -a

if I press ctrl+shift+c the output is ^C 3 0003 0x03

if I press ctrl+c the output is ^C 3 0003 0x03

if I press shift+c the output is C 67 0103 0x43

so the shift and ctrl keys works if they are combined with other keys but not together

Using the xev command and then ctrl+shift+c:

KeyPress event, serial 36, synthetic NO, window 0x3600001, root 0xb0, subw 0x0, time 4228802, (350,407), root:(399,489), state 0x2010, keycode 37 (keysym 0xffe3, Control_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

FocusOut event, serial 36, synthetic NO, window 0x3600001, mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0x3600001, mode NotifyUngrab, detail NotifyNonlinear

KeymapNotify event, serial 36, synthetic NO, window 0x0, keys: 0 0 0 0 32 0 4 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyPress event, serial 36, synthetic NO, window 0x3600001, root 0xb0, subw 0x0, time 4235635, (350,407), root:(399,489), state 0x14, keycode 55 (keysym 0x76, v), same_screen YES, XLookupString gives 1 bytes: (16) "" XmbLookupString gives 1 bytes: (16) "" XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0x3600001, root 0xb0, subw 0x0, time 4235686, (350,407), root:(399,489), state 0x14, keycode 55 (keysym 0x76, v), same_screen YES, XLookupString gives 1 bytes: (16) "" XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0x3600001, root 0xb0, subw 0x0, time 4236136, (350,407), root:(399,489), state 0x14, keycode 50 (keysym 0xfe08, ISO_Next_Group), same_screen YES, XKeysymToKeycode returns keycode: 37 XLookupString gives 0 bytes: XFilterEvent returns: False

Other user in the same computer can use ctrl+shift+c/v on gnome-terminal, so I think its a matter of configuration in some place, I found that Ctrl+Shift is assigned in someway to layout switch, I already check if this shortcut is set on my keyboard settings but it is not, I don't know when and where was set this combination, if I can know how to disable Ctrl+Shift keyboard layout switch, maybe this will be the solution.

Also I checked the /etc/default/keyboard file:

vim /etc/default/keyboard XKBMODEL="pc105" XKBLAYOUT="us,latam" XKBVARIANT="" XKBOPTIONS="grp:alt_space_toggle"

BACKSPACE="guess"

I went to all settings > Region & Language > Input Sources Options I found that 'Alternative switch to the next source' is set to Ctrl+Shift, in that window says 'You can change these shortcuts in the keyboard settings' although if I go to keyboard settings this Ctrl+Shift is not assigned to any command, in fact it doesn't allows me to use Ctrl+Shift alone (it has to be Ctrl+Shift+key).

0

Apparently /etc/default/keyboard is not attached with local gnome configurations, because in spite of having XKBOPTIONS="grp:alt_space_toggle" the output of dconf read /org/gnome/desktop/input-sources/xkb-options was

['grp:ctrl_shift_toggle']

The solution was this line:

dconf write /org/gnome/desktop/input-sources/xkb-options "['']"

I found my answer in this post: https://unix.stackexchange.com/a/333392

Also I found an easy way in graphical mode: 1. Open the gnome 'tweak tool' or type gnome-tweak-tool on a terminal 2. Go to 'Typing' label 3. Click on 'Switching to another layout'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.