15

Virtualbox and running virtual machines have worked previously. I cannot remember what changed for it to not work anymore.

Whenever I try to launch or create a new virtual machine this error pops up:

AMD-V is not available (VERR_SVM_NO_SVM). AMD-V is not available (VERR_SVM_NO_SVM).

I have tried making new 64-bit ubuntu and 32-bit ubuntu. My existing VM also get that error. Same error always. I have tried reinstall virtualbox but that didn't help.

Setup:

  • Ryzen 7 1700x with Windows 10.
  • SVM is enabled in the bios settings.
  • I have Hyper-v turned off as other answers have pointed out.

Hyper-V is turned off

I am aware of possible duplicates but those answers was not satisfactory:

20

Try :

  • To ensure Hyper-V is totally disabled, enter in elevated Command Prompt:

    bcdedit /set hypervisorlaunchtype off
    
  • Run gpedit.msc and go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security, and set to Disabled. Do the same for CredentialGuard.

  • Check Windows Defender Security Center > Device Security > Core Isolation Details, that it is turned off.

6
  • I'm getting an error when creating a 32-bit ubuntu but I don't think they are releated. Also using a prebuilt vm works as it should. Thanks for your answer. I think specifically the gpedit part did the trick. I previously had done bcedit. Also I did a reboot, but don't know of it's effect.
    – JoakimE
    Nov 12 '18 at 13:10
  • Please, please, please @Microsoft to fix this! Feb 22 '20 at 15:45
  • 4
    I think I had to also restart the pc, at least
    – FantomX1
    Mar 2 '20 at 19:30
  • I cannot find the credential guard. There is a credential delegation. Windows version 1909.18363
    – thanos.a
    Jun 1 '20 at 23:15
  • 2
    i used bcdedit /set hypervisorlaunchtype off and rebooted now virtualbox works again
    – nwgat
    Jun 4 '20 at 2:15
2

This problem happened on my Windows 10 build 1903 after I enabled Windows Sandbox in Windows features. It was solved after I uninstalled it.

0
0

Also make sure to disable "Windows Hypervisor Platform" besides "Hyper-V" in Windows Features. Reboot and it should work without disabling anything in BIOS / bcdedit.

2
  • VirtualBox supports Windows Hypervisor Platform. Why is it required to disable this particular feature?
    – Ramhound
    Apr 15 '20 at 12:48
  • @Ramhound I have no idea tbh, I got the same error as the OP, the only change I did was disabling this and it magically worked. It may be a bug or a coincidence.
    – toster-cx
    Apr 16 '20 at 8:35
-1

For me it helped it looks like to disable and enable virtualization in bios Edit: it's very important point, however I did not take my time to resimulate it. UEFI bios type I have, -> Advanced -> cpu features -> SVM item (this is named virtualization in UEFI BIOS on ADM cpus other cpus and bioses its VTX).

I also used above bcdedit /set hypervisorlaunchtype off but it didn't seem to help.

5
  • I can't help myself but comment, why I got minus point?, I did this comment tbh not for you, but for me guys, as it helped me, so I presume it works. I used the above command, but not even restart helped, I might try to reproduce. So disabling and enabling, might be sometimes the case to clear some cache I assume.
    – FantomX1
    Mar 2 '20 at 19:29
  • I downvoted your answer because it's a comment and does not answer the author's question. The author had already enabled SVM according to their answer.
    – Ramhound
    Apr 16 '20 at 9:26
  • ok, although the question is too much generalized, I did not find another question of its kind on Google, the question is generalized almost to the extent of saying 'Your computer could not start', so needs various solutions. I don't think it's a comment, I mentioned the chosen answer just because it did not work for me. Maybe it was a misunderstanding but I tried it at least 10 times, enabling alone did not help, I had to disable and reenable (sort of restart) in combination with using the bcedit command. The author mentioned had it enabled like me prior, not 'reenabling'.
    – FantomX1
    Apr 25 '20 at 15:59
  • The author accepted an answer 2 years ago. It sounds you had a similar issue but the same issue as the author. I still believe this to be commentary.
    – Ramhound
    Apr 25 '20 at 23:21
  • ok thanks, I take your point then, my logical deduction was like, enabling it in the bios was not mentioned the slightest in the chosen answer, I had a different comment there, if it was I would comment to add to it as a supplement. To be honest, I checked your profile and you are a very loyal contributor, so it adds weight to your reasoning even more, anyway I will leave it up to general publicity free will (like you did, thanks) might help some edge cases or not, as I am not knowledgable to explain my solution now as its a low/"hardware" layer.but deal with the answer, comments as you prefer
    – FantomX1
    Apr 26 '20 at 20:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.