0

This question already has an answer here:

How do I completely delete all the files for pre-installed applications (e.g. CandyCrush) in Windows 10?

e.g. I want to remove the directory for CandyCrush C:\Program Files\WindowsApps\king.com.CandyCrushSaga_1.1380.6.0_x86__kgqvnymyfvs32 but Windows won't let me.

It says SYSTEM isn't giving me permission.

I have tried running a Windows PowerShell as Administrator and I tried running the command:

Remove-AppxPackage king.com.CandyCrushSaga_1.540.1.0_x86__khqwnzmzfus32

But I get "Deployment failed"

Background: I want to get rid of all the stupid .JPG files associated with CandytCrush. I deeply resent the high-handed approach of Microsoft giving us all this bloatware that none of us asked for and also making it so hard to get rid of. It is wasting the space on my hard disk. And I don't want to see those .JPGs cluttering up my search results when I use Everything Search.

EDIT01: CandyCrush does not appear to be installed. But I want to delete the installation files(!)

marked as duplicate by Ramhound, music2myear, Toto, bertieb, K7AAY Nov 20 '18 at 18:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

In the article Windows 10 keeps installing Candy Crush games, the author has collected all known remedies, which I'll summarize below.

It should be noted that the situation on every computer is different. On some Windows 10 computers Candy Crush is never installed, while on others it is impossible to get rid off. The solutions below might or might not help, singly or several together. Even if they help, this might only be temporary.

  1. Perform a clean boot and uninstall Candy Crush.

  2. In an elevated Use PowerShell session enter the commands:

    Get-AppxPackage -User {your-user-name}   (use below the Candy Crush name)
    Remove-AppxPackage king.com.CandyCrushSaga_1.{found above}
    
  3. In regedit, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsStore\WindowsUpdate\AutoDownload, find AutoDownload or create as a new 32-bit DWORD value, and set it to 2.

  4. Block Windows Update. (Somewhat desperate.)

  5. Uninstall the Windows App Updater app, in Settings > Apps, locate Locate App Updater or App Installer and click Uninstall to remove it.

  6. In Settings > Personalization > Start, disable Occasionally show suggestions in Start.

  7. Sometimes ensuring Windows is totally patched solves the problem, in Settings > Update & Security, click Check for updates.

  8. Turn off Microsoft Consumer Experience, in Group Policy Editor (gpedit.msc), navigate to Computer Configuration > Administrative Templates > Windows Components > Cloud Content, double-click Turn off Microsoft consumer experiences, set to Enabled and click OK.
    This can also be done via regedit, key HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CloudContent, double-click DisableWindowsConsumerFeatures (DWORD) set its Value to 1.

  9. Change the security policy, by running secpol.msc, go to Application Control Policies > AppLocker, choose Packaged app Rules, right-click empty space on the right pane and choose Create New Rule, select Permissions choose Deny, click Next, choose Use an installed packaged app as a reference, click Select, select Widows Spotlight from the list, click OK, move to Package name and click Create.

Not the answer you're looking for? Browse other questions tagged or ask your own question.