20

I noticed today that no .dev domains will resolve in any browser on my MacBook while trying to access web.dev; they all say “__.dev refused to connect.” I did a quick google search for site:.dev, and all of the listed domains produce the same error, despite the fact that I can load them all from my phone on the same network. I'm using 1.1.1.1 as my DNS server but had the same issue even after changing my DNS server. I looked in /etc/hosts and didn’t find anything relevant. What could be the issue?

2
  • I used .local for similar work in the past. The link below shows that .dev TLD may have have been deprecated recently. medium.engineering/use-a-dev-domain-not-anymore-95219778e6fd – Christopher Hostage Nov 13 '18 at 7:28
  • I'm not trying to spoof it for development, I'm trying to connect to a real domain on the internet. The dev behavior that got deprecated was the redirection to localhost that a lot of devs used to use. I don't think I ever had such a thing configured on my machine, though it's possible I might have. – Luke Taylor Nov 13 '18 at 15:43
46

I'd answered this in another comment, but found this answer in another thread helpful:

https://stackoverflow.com/a/55223730

I'm answering here as Google led me here first, and so I can put some extra context for old Rails devs. If you used Pow or a similar service, it had you put a file in /etc/resolver called dev that looks a bit like this:

# Lovingly generated by Pow
nameserver 127.0.0.1
port 20560

Deleting the file (sudo rm /etc/resolver/dev) will clear this issue up.

4
  • 2
    Awesome, that did it for me. I've tried everything else, including uninstalling pow, but this file was never mentioned anywhere and is not removed during uninstallation. – Chris Oct 3 '19 at 16:40
  • 2
    PS: this was especially frustrating because while .dev domains did not resolve in any browser, they resolved just fine on the terminal, using host or nslookup. – Chris Oct 3 '19 at 16:42
  • this made my day – tam5 Jan 13 '20 at 20:24
  • I wasted so much time on this issue, thank you for posting. Life saver. – Chris Hough Mar 27 at 16:28
2

Try with https:// instead of http:// in the address bar. And check the firewall, and try another browser. Try disabling the browser's parental controls and extensions. Opening an "incognito window" or secure browsing session does that, unless you enabled extensions there too.

Also clear the browser cache. Apparently, that's now the preferred, if not the only, way to clear 301 redirects.

To make sure DNS is working, drop to a terminal and type dig web.dev. The dig command queries the DNS server for detailed address information. Try going directly to the listed IP address in the ANSWER SECTION, in this case, https://216.239.34.21.

web.dev.        162 IN  A   216.239.34.21

Update: Also check that a DNS server, such as dnsmasq, isn't configured to direct .dev to localhost in dnsmasq.conf or similar. Change dev to test, invalid, or localhost as per RFC 2606.

#address=/dev/127.0.0.1
address=/test/127.0.0.1
7
  • Incognito and https don't fix the problem. dig does resolve the right IP. Navigating directly there yields a 404 because of the way Google has their webserver for the site set up, though – Luke Taylor Nov 13 '18 at 15:42
  • That's interesting. Can you ping -c 1 web.dev and get the right address? If so, that probably rules out the OS resolvers and firewalls. Are you using Chrome or Safari? DesktopServer could also be misconfiguired and running. There is information on changing the .dev TLD docs.serverpress.com/article/… – hellork Nov 13 '18 at 20:08
  • ping -c 1 web.dev shows it resolving to localhost (PING web.dev (127.0.0.1): 56 data bytes) – Luke Taylor Nov 13 '18 at 20:22
  • 1
    @LukeTaylor Did you ever manage to resolve this? – John the Painter Apr 3 '19 at 8:58
  • 1
    For the sake of continuity, I'd found another solution for this: stackoverflow.com/a/55223730 The short of it is I used to use Pow for Rails development, which treated .dev as a local domain. Never took it out, so it was sitting there in /etc/resolver – baweaver Apr 26 '19 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.