1

I am using Ubuntu 14.04 and followed the instructions to install asterisk from this link Ubuntu 14.04 Asterisk server installation

All worked well until I run asterisk and get a shared lib error.

asterisk: error while loading shared libraries: libasteriskssl.so.1: cannot open shared object file: No such file or directory

further examining of the dynamically linked lib using "ldd"...

$ldd /usr/sbin/asterisk
linux-vdso.so.1 =>  (0x00007fff2d50a000)
libasteriskssl.so.1 => not found
libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f7315902000)
...

...reveals that the symlink is missing. I know how to create a symlink but the question is from where do I create the link?

0

Found the answer in this link

https://community.asterisk.org/t/asterisk-does-not-start/74617

Please run

find / -name libasteriskssl.so.1 -print

to locate your library and then check if it is one of the directories listed in /etc/ld.so.conf

If not, add it and run “ldconfig -v”

if yes, try just running “ldconfig -v” and check if the library is now cached

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.