51

After updating system to Mojave when I use Cmd ⌘ Tab ⇥ shortcut it behaves strangely.

I have opened many Chrome windows on different desktops.
When I have focus for example on Sublime Text, and I had focus before on Chrome, then when I press Cmd ⌘ Tab ⇥ it should switch to the Chrome window that is on the same Desktop that active Sublime is, but it doesn't. It switches to a Chrome window on a different Desktop.

It is very frustrating for me because I need to hide all Chrome windows except one, to avoid this behaviour.

8
  • 7
    Same problem here after updating to Mojave. I disagree with @Tetsujin as I have different project actively working on different Spaces, and each of them has its own Chrome window and text editor etc. However I found this problem only occurs for Google Chrome, not any other app, Safari doesn't have this "bug", so I wonder if it's not Mojave but Chrome? or both together? – DaxChen Nov 24 '18 at 6:08
  • 6
    Not sure what @Tetsujin is talking about, actually I have been doing this for the last 10 mac os versions and this is entire part of my workflow. This is just a bug of Mojave, not us using it wrongly. – adriendenat Dec 12 '18 at 11:30
  • 2
    I'll try to provide a video of the issue. I don't think this is the normal way Spaces are supposed to work, especially as this is not consistent, this happen only in certain situations. – adriendenat Dec 12 '18 at 11:44
  • 7
    @Tetsujin you can see the bug here youtube.com/watch?v=rdGTtuC-gS4 – adriendenat Dec 12 '18 at 13:17
  • 4
    @Tetsujin Grsmto is absolutely right, and the answer proposed below by aceoak (create new space, cycle through all spaces to drag Chrome windows to new space, then drag them back from the new space) confirms that this is a Mojave bug, not a Chrome one. – Jonathan H Dec 21 '18 at 12:43
31

I also have this problem. It seems to be more prominent after waking up from sleep.

One temporary fix I use: create a new space in Mission control, drag all the Chrome windows in the "focus-hog" space to the new space (in Mission control, click and drag the Chrome icon up onto the new space), and then drag them back. This seems to reset the behavior for all spaces with Chrome windows.

7
  • 4
    Ha, that's weird, but it works! :) This proves that it is indeed a Mojave bug, and neither a Chrome bug nor a feature of Spaces. – Jonathan H Dec 21 '18 at 12:47
  • Thanks for this simple, yet effective workaround. It has been plaguing me... :/ I can omit creating a new space, and assemble all Chrome windows in the space of the offender (aka focus grabber), and then redistribute to my likings. – f4lco Jan 25 '19 at 13:36
  • 1
    It works! I haven't been able to use cmd+tab to switch back to Chrome for ages. It would always change spaces and take me to a different Chrome window. – bzle Apr 1 '19 at 19:15
  • 13
    I found a simpler workaround: after cmd-tab switches to Chrome on the wrong desktop, minimize that chrome window. cmd-tab back to the other app. The cmd-tab behaviour will be fixed. Now, you can restore the minimized chrome window and the cmd-tab behaviour stays fixed. – user3392439 Apr 3 '19 at 6:52
  • 3
    @user3392439 This does seem to work, thanks! Such a frustrating bug, it's been there for ages, c'mon Apple! – Jaime Cham May 9 '19 at 8:33
0

At least for me, and in the Chromium bug reports someone else linked, this issue was directly caused by using App Exposé (this may now be called "Application Windows"). Since this functionality wasn't really important to me, I simply turned off my keyboard and mouse shortcuts for Exposé, and I haven't had any problems since. (You can do this by going to System Preferences > Mission Control > removing the shortcuts for Application windows, and also disable in the Hot Corners menu if it's there.)

Update: this seems to be fixed as of Chrome 78.0.3904.70 (https://bugs.chromium.org/p/chromium/issues/detail?id=990461)

Not the answer you're looking for? Browse other questions tagged or ask your own question.