0

I've been using an old version of Office 97 (with Macros disabled for security) for some time. Recently I got a new Windows 10 v1803 PC and re-installed Office 97. With the Office 2007 Compatibility Pack installed, Word opens every .docx file I've tried...but Excel always fails to open .xlsx files with this message:

.xlsx file not recognised

I have tried:

  • Opening file in Google Sheets and exporting as a fresh .xlsx file
  • Installed SP1, SP2 & SP3 for Office 2007 Compatibility Pack
  • Renamed the extension from .xlsx to .xls (why this is supposed to work beats me, but I found this suggestion in an online search)

Always the same result of "Not recognised". This worked on my earlier Windows 8.1 machine. Any ideas?

UPDATE

Based on one of the comments, I upgraded my installation from Office 97 SR-1 to SR-2. However, the result is the same: Word opens .docx files but Excel is not able to open .xlsx files. The Compatibility mode for Excel has also been switched between Off and various Windows XP modes without helping.

  • Does the file name contain any reserved characters? Does the file have 2 extensions (have you turned on show extensions)? – spikey_richie Nov 15 '18 at 15:46
  • Ideas: Install a current MS Office version; install the free WPS. – GabrielaGarcia Nov 15 '18 at 15:46
  • Have you set Office 97 programs to run in Compatibility Mode? What if you run Excel.exe in compatibility mode (assuming Office 2007 compatibility pack is installed) and try to open the file from File - Open Menu? – patkim Nov 15 '18 at 16:11
  • note that a xlsx is a zip file of many xml files. rename it to .zip, and look at the details. my guess is that there is a feature used that the converter doesn't understand, or you don't have zip installed? – Aganju Nov 15 '18 at 16:12
  • 1
    While you check out the file as @Aganju suggests, you may as well look at the version of Excel the XLSX was saved in (in \docProps\app.xml. It might be that the compatibility pack can't handle files saved with more recent version Excel than 2007. – cybernetic.nomad Nov 15 '18 at 16:24
0

The Microsoft Office Compatibility Pack Service Pack 3 (SP3) is supposed to enable using the new format in older Office versions.

You should be using Office 97 SR-2 with all possible updates.

Better take backup of your installation before starting, just in case.

If Service Pack 3 is too recent for your setup, then there also exist
Microsoft Office Compatibility Pack Service Pack 1 (SP1) and Microsoft Office Compatibility Pack Service Pack 2 (SP2).

  • Have tried SP1, SP2 and SP3 with the same issue...but just checked my Excel Help > About and am using Office 97 SR-1. That might be the problem, then. Wonder why it worked on Windows 8.1 then. Note that Word opens .docx fine. – AlainD Nov 15 '18 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.