2

Normally I type using a Swedish QWERTY layout. Recently I've been learning Dvorak as well. So I added "United States Dvorak" in Windows and it worked fine. If I pressed Win-Space I toggled between the two keyboard layouts.

However, I went and installed Programmer Dvorak Keyboard Layout. I followed the instructions so I had both "Swedish QWERTY" and "Programmer Dvorak". The problem was that, pressing Win-Space to toggle between them wasn't working anymore.

The instructions on the website states:

In some builds the layout doesn't appear in the switcher unless the same workaround as for Windows 8 has also been applied.

Windows 8 and 8.1 Windows 8 and 8.1 seem to have a problem with custom keyboards; they install fine but are not recognized by the user interface. You can use this work-around to activate Programmer Dvorak:

Follow the official procedure to add "English" as a language and activate "English (United States)" as the default layout.

Run these commands at the Command Prompt:

reg add "HKCU\Keyboard Layout\Substitutes" /v 00000409 /t REG_SZ /d 19360409 /f

reg add "HKCU\Keyboard Layout\Preload" /v 1 /t REG_SZ /d 00000409 /f

Log off and back on again. If you want to have one of the built-in layout enabled too, you should follow the above instructions first, and then add it afterwards.

I followed them, but I instead made it first so I only had "Swedish QWERTY" selected. After restarting, I now have 4 entries in my keyboards:

enter image description here

I only want one "Swedish Keyboard" and one "Programmer Dvorak Keyboard". But I have no idea how to remove those others ones. If I go to my language settings I see this:

enter image description here

Under "English (United Kingdom)" I see this:

enter image description here

Under "English (United States)" I see this:

enter image description here

So there seems to only two keyboards installed, but four are showing up. Does anyone have advice on how to get this fixed?

1

After some experimentation, here's what I did:

  1. I was unable to click "Remove" on either keyboard, as you can see in the screenshots
  2. I was unable to delete the language "English (United Kingdom)"
  3. I selected "English (United Kingdom)" and clicked the Down Arrow to move it to below "English (United States)"
  4. I could now select and delete "English (United Kingdom)"
  5. I now only had "English (United States)" left and inside of it was only "Programmer Dvorak". I pressed "Add a keyboard" and selected "Swedish QWERTY"
  6. The switch keyboard dialogue still showed 4 languages, but in the wrong order
  7. Restarted my computer twice
  8. Success! Now I have only the two keyboard layouts:

enter image description here

My only problem now is that I want to default to "Swedish Keyboard" instead of "Programmer Dvorak". I do not know how to change the default one. There are no arrows to move them up or down in the language settings. I dare not experiment further :)

(Note that this reset all my date/time formatting in Windows, but search "Change the date and time" in the settings and you will be able to switch it back)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.