16

When creating shortcuts, there was a checkbox to activate an option to open the tab in a new window as a standalone app (no address bar, ...). This was handy to 'install' Gmail or Slack as 'apps.'

Since few versions ago, I no longer can activate this option. Also, when I create a new shortcut, the icon no longer shows the site's favicon, but rather the Chrome icon.

Is there a way to get it back?

3
22

This option has been removed for some incomprehensible brainstorm by the Chrome devs. It might still be possible to force it by this method:

  • Go to the webpage
  • Choose More Tools > Create Shortcut (which will appear on desktop but not as an app)
  • Go to chrome://apps
  • Right-click on the new shortcut and choose Open as window
  • Right-click again on the shortcut and choose Create shortcuts...
  • Choose where to store the shortcut and click Create

This will create the right shortcut with the appid= parameter exactly as before.

However, with Chrome, it's unknown how long this method will keep on working.

1
  • Instead of creating a shortcut at the second to last step, I just opened it and pinned it to my taskbar, which is what I was planning on doing with the shortcut anyway. – FragmentalStew Dec 25 '20 at 17:02
6

The checkbox seems to be back as of Chrome build 72.0.3626.109. Hallelujah!

chrome - create shortcut dialog

1
  1. Navigate to the webpage
  2. Click menu (three dots) > More Tools > Create shortcut..
  3. Check "Open as window" and press "Create" Button
  4. This should open the webpage in a New Window (if it doesn't go to step 8)
  5. For taskbar Pinning: Right click icon showing on taskbar and select pin to taskbar
  6. For Start Menu Pinning: Right click icon showing on the taskbar, and from the popup right click on the icon of the app and select Pin to Start.
  7. Close Window and see if the icon remains where you pinned it.
  8. If the icon is not there or the icon reverts to the generic chrome icon, first make sure the apps is closed and unpinned and
    • Navigate to chrome://apps/
    • Launch app by clicking on it
    • Repeat steps 5 through 8
0

Adding to @Tolga's answer, I have multiple gmail accounts and created shortcut for all of them. However, only one of them opens as window even though I select "Open as window" for every shortcuts.

It seems to be a bug that the other shortcuts did not have "Open as window" turned on even you have checked the checkbox.

To fix them, go to chrome://apps, right click on the shortcuts and check the "Open as window" there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.