0

I'm trying to use a spare router as a wireless access point on my network - I've given it a static address and disabled DHCP, however when I plug this into the network I end up with two ipv6 addresses!

C:\Users\Matthew>ipconfig /all
Ethernet adapter Local Area Connection:

[...]
IPv6 Address. . . . . . . . . . . : 2a01:4b00:**********(Preferred)
IPv6 Address. . . . . . . . . . . : fd00::6010::**********((Preferred)
Temporary IPv6 Address. . . . . . : 2a01:4b00::**********((Preferred)
Temporary IPv6 Address. . . . . . : fd00::4d49::**********((Preferred)
Link-local IPv6 Address . . . . . : fe80::6010:d805:cfdf:8f55%34(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.69(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Saturday, November 17, 2018 10:59:27 PM
Lease Expires . . . . . . . . . . : Sunday, November 18, 2018 11:00:11 PM
Default Gateway . . . . . . . . . : fe80::325a::**********
                                   192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 239372891
DHCPv6 Client DUID. . . . . . . . : :**********
DNS Servers . . . . . . . . . . . : 2a01:4b00::**********::1
                                   192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Why do I end up with two IPv6 addresses? How can I monitor / prevent this?

Also even though there's a single IP address, there's only 1 (IPv6) DNS server address. It seems that windows is picking arbitrarily. Only one of the routers has DNS enabled so this is a problem.

  • How are the two routers connected? – Xen2050 Nov 18 '18 at 8:11
  • I have a cable connecting a LAN port of one router to a LAN port on the other router. – Matthew Nov 18 '18 at 9:57
  • Set WAN settings to manual IP assigning and put in IPv4 and IPv6 some setting as static that point to nowhere (IPv4: 10.111.222.3 and IPv6: fd3b:738e:0c41:1fdb::1) on that second router that you going to use as access point only. Also LAN network should be the same on both routers and WAN port on the second (WiFi AP) router shouldn't be connected to anything. Try to reflash it to OpenWRT if it supported if it doesn't help – Alex Nov 18 '18 at 10:33
1

One quick way should be to connect the second wifi-only router's wan port to a lan port on the main router. The wifi-only router will see the main router's network as "the internet", and have the wifi router just use it's default configuration.

Connecting to devices on the wifi router's network might be tricky, perhaps requiring port forwarding on both routers, but this setup should be fine for most general net & web access.

  • I figured this would work of course, but I was hoping for a simple brige setup. The thing that really surprised me is that if I switch off DHCP on my second router I'd expect it to take no further role in routing. However it obviously is. Is the firmware to balme or is this expected? – Matthew Nov 18 '18 at 9:58
  • A router is not designed to be used as only an access point. IPv6 doesn't need DHCP for addressing, in this case it uses router advertisements. You can consider the lack of a setting to turn those on/off a bug, but considering that you're using the router for something for which it wasn't designed that's debatable... – Sander Steffann Nov 18 '18 at 11:09
  • 1
    Third party firmware such as OpenWrt/LEDE can "turn off the router" and act as only an AP, but your average home router generally doesn't do this, because they want to be able to sell you the same hardware with different firmware for more money... – Michael Hampton Nov 18 '18 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.