0

I configured my routers DHCP to use Level 3 DNS which is 209.244.0.3 and 209.244.0.4 and it is also correctly shown when I check via ipconfig /all:

ipconfig dns output:

enter image description here

But when I check via DNSLeakTest (or any other leak tests) it always shows OpenDNS.

dnsleaktest result:

enter image description here

I made sure network adapter settings are set to automatic, I tried ipconfig /flushdns and more but still no luck. Also other computers and devices (android, ios) correctly show Level3 on DNSLeakTest. So what might be the cause and how to fix it?

2
  • That is not consistent with your pictures. If your PC used DHCP there should only be the (forwarding) router as DNS server with his internal IPv4/IPv6 addresses.
    – LotPings
    Nov 18 '18 at 14:42
  • @LotPings It is perfectly consistent. DHCP is just used to push DNS configuration to clients, and it can push whatever DNS server addresses you give it. You don't even need to have any DNS forwarder in your LAN at all.
    – TooTea
    Nov 21 '18 at 21:40
2

Your ipconfig output shows that your machine is currently configured to use three DNS servers: fe80::1 and the two you have mentioned. The preferred (primary) one is fe80::1, because IPv6 services in general take precedence over IPv4 services. Most of your DNS queries will thus be serviced by this cache.

An address in the fe80::/16 segment denotes a link-local address, so it most likely belongs to your home router, which is in turn configured to forward all DNS queries to the OpenDNS caches.

If you're wondering how the fe80::1 got there, it was probably configured automatically using DHCPv6.

1

I can't repeat your test : If I set my DNS to 209.244.0.3, then DNS Leak Test reports it as "Level 3 Communications" in the United Kingdom.

Evidently, you are not using the DNS server you think you are. I can see these possibilities:

  • You made some mistake in entering the DNS server
  • Your ISP is hijacking your DNS queries
  • Your computer or browser are infected with a DNS hijacker.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.