0

When I try to access my flash drive by double clicking I get prompted with an Application not found. Right clicking and selecting open works... only to send me to an empty folder named E:. Clicking properties brings up the correct amount of free and used storage space. So I believe all my files are still present.

I run a Window 7 32-bit machine

Up till yesterday functions were normal. I plugged my drive into a windows XP machine no problem with the possible exception of creating some shortcut to the drive that I can no longer access.

This only happened after I plugged into the Windows XP computer. Switching ports does not help.

0

There is a good chance that the Windows XP computer may have been infected with a virus. I would suggest that you scan the flash drive and delete the Autorun.inf file in the root of the drive. This file may be hidden. It may have also hidden the rest of your files.

In Windows XP (and possibly prior), if there was an Autorun.inf in the root of the drive, this file would be read when double clicking on the drive in My Computer to specify an executable to run. This was done to make it easy for software manufacturers to run installations without having to provide instructions on where to start.

This pretty quickly became a target for viruses, which would copy themselves into every drive and create an Autorun.inf file that would run the virus executable. This was a very effective way of attacking entire business networks, since network shares worked the same way.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.