5

I have a three monitor setup on my new Win10 machine and I'm trying to hide the system tray icons - it just doesn't work.

I know how you are supposed to do it via "Taskbar Settings" and "Select which icons appear on the taskbar", but whatever I set there, the icons are never hidden. Turning the system icons on and off seems to work (e.g., volume) but I can't hide my application icons.

Everything I can Google seems to describe where to find the settings / controls for this - but not what to do if that doesn't work.

Anyone got any clues?

EDIT:
Tray Icons - no extension

Tray Icons - no extension

Notification settings

Notification settings

EDIT 2: I just had to install more software which added more Tray icons...this is getting worse, does nobody have any ideas?

  • Indeed, applications can push themselves as "active" to be placed out of the hidden icons, and usually that can only be solved by a setting in that particular app. It is meant to make the user understand something changed and they want to notify you. There probably is some software out there that can remove icons from the system tray entirely, but I don't know any app that could do this. My suggestion would be to look into the settings of these apps to see if you can disable the systemtray icon there. – LPChip Nov 19 '18 at 22:14
  • But I don't want to disable them, I want hide them like I used to be able to, and have the 'up arrow' extension area available so I can access them when I need them. Why has Win10 retained the option to hide the icon if it doesn't work? – Kyudos Nov 19 '18 at 22:19
  • It works by design, but there's another reason why these icons pop up out of the hidden area. For example, if you set outlook to be hidden, and you receive an email, outlook will pop out of that area to notify you that new email arrived. By default it will remain there for a certain amount of time and periodically check if you have read the mail it notified you. If so, that icon will disappear back into the hidden icons area. Some programs abuse this or the developer just wants their icon always visible. In any case, it should be searched for in that program. Maybe contact the developers? – LPChip Nov 19 '18 at 22:22
  • That's nuts - the system tray belongs to Windows Explorer, so it (Explorer) should give me ultimate control over what gets shown. It used to work like that no? I can't (and shouldn't have to) persuade multiple developers to 'fix' their system tray icons. But honestly, I don't think that us the problem - I can't even hide (for instance) my Outlook icon - are you saying Microsoft themselves can't even do this right? – Kyudos Nov 19 '18 at 22:27
  • There is a setting in outlook to disable that icon. If my memory serves me right, File, Options, email, notifications, show icon when new email is received. – LPChip Nov 19 '18 at 22:51
6

I discovered the solution by trial and error / accident.

Google-fu suggested that this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

was related to numerous Tray related problems so I looked there and found a REG_DWORD entry labelled:

NoAutoTrayNotify

which was set to 1. I changed it to 0 and restarted Explorer et voila my system tray starts working again. I've no idea how this got set in the first place, but I'm happy now anyway.

This link tells us "This setting determines whether the items are always expanded or always collapsed." which sort of suggests it should be controlled by the Win10 option "Always show all icons in the notification area", but toggling that option had no effect for me - even with Explorer restarts.

  • Just a further note for anyone interested...it appears to be AutoDesk's Autocad Desktop App that breaks this. I'll bring it up with them. – Kyudos Jan 25 at 0:08
  • Something strange happened on this two monitor setup when the secondary (which purports to be the primary) monitor stole all the primary taskbar icons when adjusting the displays. Swapping the displays with "Make this my main display" brought them back, along with the RH systray. No entries at all in the above registry key, however. – Laurie Stearn Feb 17 at 14:11
  • I had to make sure the "Always show all icons in the notification area" toggle was On, restarted Explorer, then turned it Off. Then this fix worked for me. – Tim R. Aug 16 at 23:42
1

A new "sneaky" feature of 1809 (1803?) allows one to hide icons into the area above the up-arrow thus:
Drag them from the taskbar and hold them over the up arrow, whereupon the window opens for the icon to be popped in a location of one's choice.

0

In order to hide the icons in the taskbar ,right click on the taskbar and select “unpin this program from the taskbar” In order to hide the icons from the system tray , click the arrow button at the right bottom of the screen (next to the notification symbol) , then select customize , you will be taking to another window “Notification area Icons” . There will be the list of ‘Icons’ and their ‘behaviour’.From the behaviour you can select “Hide icon and notifications” to hide a particular icon. Where you can also select “ hide the icon and notifications” or “ Only show notifications” as per your requirement.

  • 1
    I don't have an arrow button at the bottom right - that is part of the problem. – Kyudos Nov 19 '18 at 23:24
  • Press windows key type "task bar settings" then press customize and select your desired key and required behavior from the list – voxforem technologies Nov 19 '18 at 23:47
  • As per the OP - I know how to customise the taskbar, and the notification area, and (supposedly) which icons appear there - what I'm saying is none of those options do anything. It doesn't work. I don't want to turn off notifications I want to remove icons from the notification area to the 'up arrow' extension area as per Win7. – Kyudos Nov 19 '18 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.