I want to use TiKi to use as a collaboration website.

Up until Windows 10 arrived I've never had any trouble installing development tools using the LAMPP, WAMPP, or XAMPP website installers. Tools such as Redmine, TestLink, CMS, and others. Now Windows 10 installs and activates IIS whether you want it or not. Consequently, it hogs port 80 which impacts connections to MySQL and other modules down the line.

I changed Apache to use Port 8080 instead of 80 as IIS is sitting on 80. That worked for Apache, except now it package couldn't find MySQL on Port 3306 or PHP.

How do I completely disable IIS server and everything it is now hogging?

  • 1
    Welcome to Super User! It looks like you've got a couple of distinct questions- disabling IIS, and sorting out MySQL and PHP. I would recommend that you edit your question and focus on one thing at a time, such as disabling IIS. You can then How to Ask a separate question with more details about MySQL and one for PHP if needed at that point. Cheers! :)
    – bertieb
    Nov 20, 2018 at 19:00
  • “Now Windows 10 installs and activates IIS whether you want it or not.” – It most certainly does not. You might want to check [my answer] on a related question.
    – Daniel B
    Nov 20, 2018 at 19:24
  • @DanielB you omitted the link- I would add it myself but I wasn't sure which one of your 859 answers it was :)
    – bertieb
    Nov 20, 2018 at 22:43
  • 1
    Whoops. P: Here’s the answer, this time for real. :)
    – Daniel B
    Nov 21, 2018 at 7:08
  • Where have you "tried" to install Apache/XAMPP? As I understand it, there can be permissions issues if installing to the Program Files directory. (?)
    – MrWhite
    Dec 18, 2018 at 18:53

4 Answers 4


To uninstall IIS:

  • Call Control Panel > Programs and Features
  • Click Turn Windows features on or off
  • Scroll down to Internet Information Services

    enter image description here

  • Click on the square next to Internet Information Services so it becomes empty

    enter image description here

  • Click OK and reboot if required.
  • 5
    "Uninstalling" would seem to be a bit overkill IMO. Can the "service"(?) not be simply stopped? (Or change the port that IIS listens on?)
    – MrWhite
    Dec 18, 2018 at 18:54
  • 2
    @MrWhite You stop all related services, but Windows has a nag for turning them back on after updates.
    – Mast
    Mar 6, 2019 at 22:19
  • still IIS is running and port 80 is blocked... Nov 19, 2019 at 7:53
  • 1
    This is uninstalling IIS, not disabling IIS. MegamanHxH answer is the correct one
    – Mick
    Mar 8, 2020 at 23:33
  • worked like a charm for me , thanks! Feb 22, 2021 at 9:10


The World Wide Web Publishing service, described in detail here, is a listener adapter for http.sys. The W3SVC service can be stopped and started from the Services management console. https://blogs.msdn.microsoft.com/benjaminperkins/2016/06/16/lab-6-using-http-w3svc-was-and-w3wp/

You can disable the W3SVC service by running the command


Search for "World Wide Web Publishing Service", Double-click to access the service's properties. And finally change Startup type from "Automatic" to "Manual" or "Disabled".

However, this will disable it until the next update comes, Windows will reset the settings based on Matt comment.


Stop the Web Server IIS:

  1. press (win + x)
  2. open Windows PowerShell (admin)
  3. type: "net stop WAS" and press ENTER

more info: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/jj635851(v=ws.11)

  • After pressing win+x, I don't get an option for PowerShell. There's only Command Prompt for me
    – ZygD
    Mar 13, 2021 at 15:11
  • with command prompt (admin ) should work too Mar 15, 2021 at 5:44

why not just stop the sites from running in IIS? that worked for me. I.e. in IIS Manager select the Default Web Site and click on Stop in the right hand side bar under Manage Website.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .