8

I can't enable remote desktop in Windows 10 Pro (build 1803).

I toggle the button.

pic1.

click confirm.

pic2.

but the service is not toggled on.

pic3.

However, when I check the classic way of enabling RDP, it shows the service being ticked on. But unable to remote in. I did restart the RDP service too.

pic4.

I was able to activate the RDP service by disabling the firewall rules under Public network settings.

pic5 pic6

Unsure what rules is causing this issue yet.

6
  • Where are you trying to connect from? If from outside the network, make sure you have port forwarding set up. Nov 22, 2018 at 2:13
  • I was able to activate the RDP service by disabling the firewall rules under Public network settings. Unsure what rules is causing this issue yet. see the updated images for clarity. the issue is that the service is started on the system due to some rules - something is preventing it.
    – aharen
    Nov 22, 2018 at 2:26
  • Where are you trying to access the computer from? On the same network or outside of it? Nov 22, 2018 at 2:32
  • within the same network. I have figured out the issue now. The network profile was set to Public instead of Private. Under Private, with FW enabled, you can enable the RDP service without any issue.
    – aharen
    Nov 22, 2018 at 2:34
  • 1
    added the solution
    – aharen
    Nov 22, 2018 at 2:41

1 Answer 1

8

I have figured out the issue now. The network profile was set to Public instead of Private. Under Private, with FW enabled, you can enable the RDP service without any issue. But when the profile is set for Public and with FW enabled, the RDP service isn't allowed to start by default it seems. Unless manual configurations are done.

2
  • Thanks for posting the solution! Do you want to set it as Answer? Nov 22, 2018 at 16:10
  • where should I change a network profile ? As always, windows searchbar is useless. Where is this settings located ? Aug 9, 2020 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.