0

I'm running Windows 10 October Update and in case i know that Windows 10 reduces my wallpaper quality everytime! Of course this is real!

I already followed this step:

  1. Open Registry Editor
  2. Go to HKCU\Control Panel\Desktop
  3. Create an DWORD value named JPEGImportQuality.
  4. Set it as decimal and the value to 100

But my wallpaper quality still gets reduced. For example here is an test that i made to ensure that the setting still works.

The following is the original image made in MSPaint (2MB):

http://www.mediafire.com/convkey/153d/5yingeet7scwslwzg.jpg?size_id=7

The next image shows the compressed image by Windows (85kb):

http://www.mediafire.com/convkey/6816/kniw41nx21x7wzjzg.jpg

Everytime when I set the wallpaper, it reduces the quality. How can i solve this in the new Windows 10 update?

  • JPEG is designed for images with gradients, like photos. The compression messes up low-color artwork and text. I don't know if only jpg images can be used for wallpaper, but an alternate solution would be to see if you can use an image with lossless compression. For example, try saving the original image as a gif. – fixer1234 Nov 23 '18 at 23:22
  • 2.188kb is not less than 85kb. What am I missing? – I say Reinstate Monica Nov 24 '18 at 0:46
2

Windows saves the compressed version of the background image to the following directory:

C:\Users\USERNAME\AppData\Roaming\Microsoft\Windows\Themes

It's stored there as a file named TranscodedWallpaper that has no file extension.

Rename the TranscodedWallpaper file to something like TranscodedWallpaper_old, just in case, and replace it by the original image, also renamed to TranscodedWallpaper with no file extension.

The image should now display with no degradation.

| improve this answer | |
  • I moved the full quality image now. What should i do next for the changes to take effect? – user902190 Nov 24 '18 at 10:24
  • Logoff/on or reboot. – harrymc Nov 24 '18 at 11:03
1

I had the same issue.
Here's the solution:

  1. Go to folder options (Open documents, go to "View" on the ribbon and select "Options" on the right)
  2. Go to the "View" tab
  3. Uncheck the "Hide extensions for known file types" option.

The only thing left to do now is rename your .jpg image to .jpeg.
Right click on the Image and set it as background.

For some reason, if the image isn't .jpeg (and it's .jpg) it gets compressed.

| improve this answer | |
0

When you're setting a wallpaper, you don't wanna set it from the Windows Photo Viewer.
Instead, set it directly from the image file, right click and choose Set as desktop background.

I've made a comparison and here is the result:enter image description here

| improve this answer | |
0

Another possibly safest solution is to save the image as PNG and set it as the background. As of today, Windows 10 did not compress the PNG images I tried to set as backgrounds. I think the compression happens only with JPG images(thus the registry name JPEGImportQuality, maybe).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy