-1

I'm having trouble connecting to my local webserver externally. I use a Netgear R8000 Nighthawk X6 AC3200 Router. Here is everything I've done so far:

  • I enabled remote management on a port 12900 via Advanced->Adv. Setup-> Remote Mgmt

  • I've enabled dynamic dns using Advanced->Adv. Setup->Dynamic DNS. After this, browsing to the 'dyn. DNS host name' (on port 80) would take me to the router portal. So would https://{'dyn DNS host name'}:12900.

  • I set up a webserver (IIS) on my home network and configured 3 sites to be accessible on port 80, 9100 and 9101. I set up the firewall so that other machines on the network can access these sites.

  • I then (tried to) enabled external access by going to Advanced->Adv. Setup->Port Forwarding & setting up 2 rules,

    • One rule to direct incoming traffic on port 9100-9110 to {local web server IP} port 9100-9110.

    • A second rule to direct traffic on port 80 to {local web server IP} port 80. I had to select 'HTTP service' since it doesn't let me set custom rules for 80 and 443.

Here is what is happening:

  • pinging dynamic DNS host name resolves correctly.

  • Inside my network, browsing to http://{dyn DNS host name} on port 80, 9100 or 9101 works correctly from local machine/phone.

  • externaly, browsing to https://{dyn DNS host name}:12900 works and takes me to router administration page

  • externally, browsing to http://{dyn DNS host name}:9100 or http://{dyn DNS host name}:9101 works.

  • externally browsing to http://{dyn DNS host name} or http://{dyn DNS host name}:80 does not work

If I make another port binding (say 9102) to the port 80 site, it works externally. Only port 80 keeps failing!!

I've tried many many things but it refuses to work. Please help.

6
  • 1
    There's quite a bit of complexity to this problem currently. It might be best to take one step at a time. I suggest removing DNS from the equation - find out your remote IP by Googling whatsmyip then attempt to connect by IP. Disable remote management - you're only interested in being able to access your webserver, not your router admin interface (potentially a security hole). Then try to connect to your internal IIS via an external connection (VPN or maybe your mobile device). Post how you get on.
    – moo
    Nov 24, 2018 at 15:47
  • 1
    Some ISPs block port 80. You may be able to use port 8080 instead. (Browsing to a site on port 8080 Windows Server 2008 IIS 7) Nov 24, 2018 at 15:56
  • and some routers by default block access to port 80 on the WAN side and allow it only from the LAN side. so you can't forward port 80 externally to internally
    – Zina
    Nov 24, 2018 at 15:59
  • 1
    This sounds like the router is binding to port 80 and not allowing traffic to be forwarded on the router. Fixing this may be none trivial as it's a common bug in router software. Can you change the port for the router control panel, or turn off http and allow it to only bind to https?
    – davidgo
    Nov 24, 2018 at 17:45
  • Not sure why this got a downvote. Seemed like a legit question framed properly. Anyway, @Mark, I disabled remote management and now I can't connect to it on port 12900 externally. The IIS situation hasn't changed. I can still connect to the other ports 9100,9101 but not on port 80 (Chrome says This site can't be reached...connection was reset).
    – Ash
    Nov 26, 2018 at 1:44

1 Answer 1

0

As stated in the comments ... Most Internet Service Providers block port 80. If you review your agreement with your provider you will find that you are not permitted to host a website on a residential class service.

So, port 80, 443, 25, 21 and more are all blocked by default by most Residential Internet Service Providers. To Get around this you can add a port forward to your router to route your port 80 traffic to port 9103, for example.

And please, as commented by Mark, turn off the remote management feature of the router unless you absolutely must have it enabled.

5
  • 1
    I believe this is incorrect. Last I looked, Services like dyndns only provided DNS to IP mapping, not port forwarding. Do you have any evidence to support your assertion?
    – davidgo
    Nov 24, 2018 at 17:41
  • @davidgo thank you. Yes, you are correct. I had another service confused with dyndns. Answer updated. Nov 25, 2018 at 5:07
  • Thanks @Steven for your answer. My ISP's tech support seem to be inconclusive on this. You said I could workaround this by forwarding port 80 to my local machine's port 9103 (for example) but wouldn't the ISP blocking be before the request hits the router. Also, I can tell you that I can't see any port 80 requests in the router logs at all but I can see all other requests.
    – Ash
    Nov 26, 2018 at 1:51
  • This may be true in some markets. In the UK, anecdotally I've never had a problem connecting to port 80 externally.
    – moo
    Nov 26, 2018 at 8:41
  • @Ash In many markets the ISPs only block the common ports e.g. 80,443,21,22,25. I am a COX subscriber and cannot route 80 to my development machine, I have to use a non-standar port like 8081 for http traffic for my development servers when needed. I believe you will be just find by having your router perform another port forward from 9103 externally to 80 internally on the designated internal IP. Nov 27, 2018 at 6:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .