0

I have for days unsuccessfully tried to troubleshoot the RPC server is unavailable error on my PC running Windows 10 education (64 bit) which started appearing a couple of days ago:

enter image description here enter image description here

I have tried an upgrade reinstall (repair) of Windows hoping it would fix the issue but it didn't. Furthermore I have also tried doing the following:

  • Restarting Remote Procedure Call service, Windows Defender,DCOM Server Process launcher services but nothing has helped.
  • Repairing component store (DISM tool)
  • Scanning system file (SFC)
  • Clean boot
  • Adding firewall exception to remote services
  • Checked online for solutions but still can't fix the issue.

Is there something I have to do the fix this error and get Windows Defender running (short of clean installing for now)?

1

Try this:

  • Logon as administrator
  • In Administration Tools > Services, ensure that the following services all have the Status of "Running" and their Startup type is "Automatic".
  • Start Windows Defender Firewall > Allow an app or feature through Windows Defender Firewall
  • Find "Remote Assistance" in the list and ensure that it is allowed for both "Private" and "Public".
  • Click OK.
  • Thanks for response I tried that and it didn't work – xavier_fakerat Nov 28 '18 at 17:20
  • +1 for putting attention into this question, despite the fact it troubles a lot of people it didn't seem to generate any attention but I'm glad I fixed the issue myself :) – xavier_fakerat Dec 12 '18 at 17:03
0

Preamble

After 2 weeks of continuous and determined investigation I finally managed to solve this mysterious puzzle (despite some serious setbacks and time loss) :)

The initial investigations were based on possible non-functionality of the Windows Defender (WD) service, which was failing to start. I spent a lot time trying various fixes such as, re-configuring firewall, re-registering system files, setting Windows services to default start-up, as well as restoring important Windows services using various scripts and commands and all of this did not work.

At this point I now didn't have a choice but to either re-install Windows or another Antivirus software (possibly a free solution) but I couldn't give up.

I even used group policy to disable and re-enable WD hoping for luck but it didn't work. I then reluctantly did a repair-upgrade, but to my surprise this didn't work also WD continued giving funny error messages like

Windows defender service couldn't be started. the system cannot find the path specified. and could not be started

I was now adamant that this was a case of messed up registry entries of WD, but I wasn't sure which entry to fiddle around with.

I then compared the WD registry entry: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinDefend] with the one on my WindowsToGo installation I still exported the latter (though they were similar) but it didn't work.

I wasn't satisfied until I further dug in the registry to find the much awaited solution...


The solution

The culprit registry entry was: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]

I loaded the hive from the WindowsToGo installation and compared it with my current and found some clues:

  1. The InstallLocation subkey had a strange key looking like %ProgramData%\Microsoft\Windows Defender\Platform\<Version> instead of %ProgramFiles%\Windows Defender thus I had to change accordingly.

  2. In order to be granted permissions of this protected registry key, I had to take ownership of the key.

I rebooted the machine, and to delight the following sreenshots summaries the whole story:

enter image description here

enter image description here

Conclusion

  • The wrong information in registry was causing (apparently it is the new path for WD in Windows 10 Creators Update) the WD to fail to start, and upon correcting all was OK. I apologise for posting the whole story but I had to, in the hope it be valuable to someone :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.