This is not a duplicate from How to Unblock Previously Unblocked CHM File

  • In my case, the chm file is not on a network drive,
  • it is on a local folder,
  • it has opened in the past without problems,
  • the registry keys are there, it tried with different values in the key MaxAllowedZone

I open this file once a week, and suddenly today it does not open It just displays an empty screen and has the waitcursor running forever. All I can do is end process thru task manager.

I need this file to be able to get my work done, so any help here would be so great

I also tried all options found here https://support.microsoft.com/en-us/help/892675/certain-web-sites-and-html-help-features-may-not-work-after-you-instal
But again it does not help

  • Are you wanting to open them for edit? Or to view? – spikey_richie Nov 26 at 8:37
  • @spikey_richie no just for reading – GuidoG Nov 26 at 8:41
  • You got Windows Help program (WinHlp32.exe) for Windows installed? – spikey_richie Nov 26 at 11:25
  • @spikey_richie Yes, I already mentioned that I open this file once a week. I have been doing this for years now it suddenly stopped working – GuidoG Nov 26 at 11:47
  • @spikey_richie WinHlp32. exe is not used for viewing CHM files. – help-info.de Nov 26 at 18:22
up vote 1 down vote accepted

I never have had this problem on my Windows 7 machine (I'm now on Windows 10).

First, please check if other CHM files can be opened.

Internet Explorer (not EDGE) settings have a direct effect on the display in CHM. Please clear the cache of Internet Explorer and / or reset all Internet options to the default settings (please be careful!) as a first step.

Another thought: The hh.dat file stores user-specific information on all the HTMLHelp files (*.CHM) on your system (position, favourite topics, search history, etc.), and may cause a error if it has somehow been corrupted.

Delete or rename the file hh.dat to reset all (!) CHM windows on your system to their default settings as a second step. Windows will create a new version of hh.dat when you next open any .chm file. You should find hh.dat at:

Windows 7: \Users\%username%\AppData\Roaming\Microsoft\HTML Help

  • Renaming the hh.dat file and rebooting did not work for me yesterday. But after trying it once again and rebooting today it does work. So its hard to say if this really fixed it, but i will accept this answer anyway. Thanks – GuidoG Nov 27 at 8:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.